summaryrefslogtreecommitdiff
path: root/modules/pam_filter
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-11-11 07:43:54 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-11-11 07:43:54 +0000
commit8a2221a5033467b39a850b2d081e30f9de1fe2e5 (patch)
tree70c722db150194dde8fc7df7d6671b96714ee614 /modules/pam_filter
parent61a4ef28627e5b08a0857754ce62ab0d7325c6cf (diff)
Relevant BUGIDs: 436057, 476970
Purpose of commit: cleanup Commit summary: --------------- general comment, make and include cleanup.
Diffstat (limited to 'modules/pam_filter')
-rw-r--r--modules/pam_filter/Makefile2
-rw-r--r--modules/pam_filter/pam_filter.c8
-rw-r--r--modules/pam_filter/upperLOWER/Makefile2
-rw-r--r--modules/pam_filter/upperLOWER/upperLOWER.c1
4 files changed, 7 insertions, 6 deletions
diff --git a/modules/pam_filter/Makefile b/modules/pam_filter/Makefile
index c1394574..48411497 100644
--- a/modules/pam_filter/Makefile
+++ b/modules/pam_filter/Makefile
@@ -18,7 +18,7 @@ include ../../Make.Rules
TITLE=pam_filter
FILTERS=upperLOWER
-FILTERSDIR=$(SUPLEMENTED)/pam_filter
+FILTERSDIR=$(SECUREDIR)/pam_filter
export FILTERSDIR
CFLAGS += -Iinclude
diff --git a/modules/pam_filter/pam_filter.c b/modules/pam_filter/pam_filter.c
index f67ec0d2..9a6fc8c5 100644
--- a/modules/pam_filter/pam_filter.c
+++ b/modules/pam_filter/pam_filter.c
@@ -150,7 +150,7 @@ static int process_args(pam_handle_t *pamh
/* the "ARGS" variable */
-#define ARGS_OFFSET 5 /* sizeof("ARGS="); */
+#define ARGS_OFFSET 5 /* sizeof('ARGS='); */
#define ARGS_NAME "ARGS="
size += ARGS_OFFSET;
@@ -174,7 +174,7 @@ static int process_args(pam_handle_t *pamh
/* the "SERVICE" variable */
-#define SERVICE_OFFSET 8 /* sizeof("SERVICE="); */
+#define SERVICE_OFFSET 8 /* sizeof('SERVICE='); */
#define SERVICE_NAME "SERVICE="
pam_get_item(pamh, PAM_SERVICE, (const void **)&tmp);
@@ -196,7 +196,7 @@ static int process_args(pam_handle_t *pamh
/* the "USER" variable */
-#define USER_OFFSET 5 /* sizeof("USER="); */
+#define USER_OFFSET 5 /* sizeof('USER='); */
#define USER_NAME "USER="
pam_get_user(pamh, &tmp, NULL);
@@ -222,7 +222,7 @@ static int process_args(pam_handle_t *pamh
/* the "USER" variable */
-#define TYPE_OFFSET 5 /* sizeof("TYPE="); */
+#define TYPE_OFFSET 5 /* sizeof('TYPE='); */
#define TYPE_NAME "TYPE="
size = TYPE_OFFSET+strlen(type);
diff --git a/modules/pam_filter/upperLOWER/Makefile b/modules/pam_filter/upperLOWER/Makefile
index 6db8d6e3..77bc4102 100644
--- a/modules/pam_filter/upperLOWER/Makefile
+++ b/modules/pam_filter/upperLOWER/Makefile
@@ -21,7 +21,7 @@ OBJS = $(TITLE).o
all: $(TITLE)
$(TITLE): $(OBJS)
- $(CC) -o $(TITLE) $(OBJS)
+ $(CC) $(CFLAGS) -o $(TITLE) $(OBJS)
$(STRIP) $(TITLE)
install:
diff --git a/modules/pam_filter/upperLOWER/upperLOWER.c b/modules/pam_filter/upperLOWER/upperLOWER.c
index c85a950a..c5f9366c 100644
--- a/modules/pam_filter/upperLOWER/upperLOWER.c
+++ b/modules/pam_filter/upperLOWER/upperLOWER.c
@@ -10,6 +10,7 @@
#include <security/_pam_aconf.h>
#include <stdio.h>
+#include <stdlib.h>
#include <syslog.h>
#include <sys/time.h>
#include <sys/types.h>