summaryrefslogtreecommitdiff
path: root/modules/pam_permit
diff options
context:
space:
mode:
authorStefan Schubert <schubi@suse.de>2023-01-26 16:20:07 +0100
committerDmitry V. Levin <ldv@strace.io>2023-02-07 08:00:00 +0000
commit96b70abec27356eba17ecc16d1c52e8cfa5c46cd (patch)
treef9f0043913373fd2cd78c310deeeb8ca182f3d14 /modules/pam_permit
parent75dceba6f3bd3f3a24018a5352674606469106e3 (diff)
build: use <vendordir>/security directory for installation if it has been set
Otherwise the corresponding files are still installed in /etc/security. * configure.ac (AC_SUBST): Add VENDOR_SCONFIGDIR. (AM_CONDITIONAL): Add HAVE_VENDORDIR. * modules/*/Makefile.am (secureconfdir): Set to VENDOR_SCONFIGDIR if HAVE_VENDORDIR has been set, otherwise to SCONFIGDIR.
Diffstat (limited to 'modules/pam_permit')
-rw-r--r--modules/pam_permit/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/modules/pam_permit/Makefile.am b/modules/pam_permit/Makefile.am
index 3fb4792c..e9a05156 100644
--- a/modules/pam_permit/Makefile.am
+++ b/modules/pam_permit/Makefile.am
@@ -15,7 +15,11 @@ dist_check_SCRIPTS = tst-pam_permit
TESTS = $(dist_check_SCRIPTS) $(check_PROGRAMS)
securelibdir = $(SECUREDIR)
+if HAVE_VENDORDIR
+secureconfdir = $(VENDOR_SCONFIGDIR)
+else
secureconfdir = $(SCONFIGDIR)
+endif
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
$(WARN_CFLAGS)