summaryrefslogtreecommitdiff
path: root/modules/pam_succeed_if/pam_succeed_if.8
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-02-24 19:17:59 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-02-24 19:17:59 +0000
commit6ed58eca47c44bd9df5222b8045ff7b322618ece (patch)
tree1bcfebe706e4b467fa1196ad651ba37dc7d4d0b9 /modules/pam_succeed_if/pam_succeed_if.8
parent547545c1cc8ab7e4e37d9650cd095fc0671bc1bf (diff)
Relevant BUGIDs: 1425487
Purpose of commit: new feature Commit summary: --------------- Cleanup of manual page and README: 2006-02-24 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_succeed_if/pam_succeed_if.8.xml: New, based on version from #1425487. * modules/pam_succeed_if/pam_succeed_if.8: Regenerated from xml. * modules/pam_succeed_if/Makefile.am: Include XML rules. * modules/pam_succeed_if/README.xml: New. * modules/pam_succeed_if/README: Regenerated from xml. * modules/pam_succeed_if/pam_succeed_if.c: Fix comment about return values.
Diffstat (limited to 'modules/pam_succeed_if/pam_succeed_if.8')
-rw-r--r--modules/pam_succeed_if/pam_succeed_if.8147
1 files changed, 115 insertions, 32 deletions
diff --git a/modules/pam_succeed_if/pam_succeed_if.8 b/modules/pam_succeed_if/pam_succeed_if.8
index da95a033..70c4f8d2 100644
--- a/modules/pam_succeed_if/pam_succeed_if.8
+++ b/modules/pam_succeed_if/pam_succeed_if.8
@@ -1,37 +1,120 @@
-.\" Copyright 2003, 2004 Red Hat, Inc.
-.\" Written by Nalin Dahyabhai <nalin@redhat.com>
-.TH pam_succeed_if 8 2004/12/27 "Linux-PAM" "System Administrator's Manual"
-
-.SH NAME
-pam_succeed_if \- succeed or fail based on account characteristics
-
-.SH SYNOPSIS
-.B account sufficient pam_succeed_if.so uid < 500
-
-.SH DESCRIPTION
-pam_succeed_if.so is designed to succeed or fail authentication based on
-characteristics of the account belonging to the user being authenticated.
-
-The module can be given one or more conditions as module arguments, and
-authentication will succeed only if all of the conditions are met.
-
-.SH ARGUMENTS
-.IP debug
+.\" ** You probably do not want to edit this file directly **
+.\" It was generated using the DocBook XSL Stylesheets (version 1.69.1).
+.\" Instead of manually editing it, you probably should edit the DocBook XML
+.\" source for it and then use the DocBook XSL Stylesheets to regenerate it.
+.TH "PAM_SUCCEED_IF" "8" "02/24/2006" "Linux\-PAM" "Linux\-PAM"
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+pam_succeed_if \- test account characteristics
+.SH "SYNOPSIS"
+.HP 18
+\fBpam_succeed_if.so\fR [\fIflag\fR...] [\fIcondition\fR...]
+.SH "DESCRIPTION"
+.PP
+pam_succeed_if.so is designed to succeed or fail authentication based on characteristics of the account belonging to the user being authenticated. One use is to select whether to load other modules based on this test.
+.PP
+The module should be given one or more conditions as module arguments, and authentication will succeed only if all of the conditions are met.
+.SH "OPTIONS"
+.PP
+The following
+\fIflag\fRs are supported:
+.TP
+\fBdebug\fR
Turns on debugging messages sent to syslog.
-.IP use_uid
-Evaluate conditions using the account of the user whose UID the application
-is running under instead of the user being authenticated.
-.IP quiet
+.TP
+\fBuse_uid\fR
+Evaluate conditions using the account of the user whose UID the application is running under instead of the user being authenticated.
+.TP
+\fBquiet\fR
Don't log failure or success to the system log.
-.IP quiet_fail
+.TP
+\fBquiet_fail\fR
Don't log failure to the system log.
-.IP quiet_success
+.TP
+\fBquiet_success\fR
Don't log success to the system log.
-
-
-.SH BUGS
-Let's hope not, but if you find any, please report them via the "Bug Track"
-link at http://bugzilla.redhat.com/bugzilla/
-
-.SH AUTHOR
+.PP
+\fICondition\fRs are three words: a field, a test, and a value to test for.
+.PP
+Available fields are
+\fIuser\fR,
+\fIuid\fR,
+\fIgid\fR,
+\fIshell\fR
+and
+\fIhome\fR:
+.TP
+\fBfield < number\fR
+Field has a value numerically less than number.
+.TP
+\fBfield <= number\fR
+Field has a value numerically less than or equal to number.
+.TP
+\fBfield eq number\fR
+Field has a value numerically less equal to number.
+.TP
+\fBfield >= number\fR
+Field has a value numerically greater than or equal to number.
+.TP
+\fBfield > number\fR
+Field has a value numerically greater than number.
+.TP
+\fBfield ne number\fR
+Field has a value numerically different from number.
+.TP
+\fBfield = string\fR
+Field exactly matches the given string.
+.TP
+\fBfield != string\fR
+Field does not match the given string.
+.TP
+\fBfield =~ glob\fR
+Field matches the given glob.
+.TP
+\fBfield !~ glob\fR
+Field does not match the given glob.
+.TP
+\fBuser ingroup group\fR
+User is in given group.
+.TP
+\fBuser notingroup group\fR
+User is not in given group.
+.SH "RETURN VALUES"
+.TP
+PAM_SUCCESS
+The condition was true.
+.TP
+PAM_AUTH_ERR
+The condition was false.
+.TP
+PAM_SERVICE_ERR
+A service error occured or the arguments can't be parsed as numbers.
+.SH "EXAMPLES"
+.PP
+To emulate the behaviour of
+\fIpam_wheel\fR, except there is no fallback to group 0:
+.sp
+.nf
+ auth required pam_succeed_if.so quiet user ingroup wheel
+
+.fi
+.sp
+.PP
+Given that the type matches, only loads the othermodule rule if the UID is over 500. Adjust the number after default to skip several rules.
+.sp
+.nf
+ type [default=1 success=ignore] pam_succeed_if.so quiet uid > 500
+ type required othermodule.so arguments...
+
+.fi
+.sp
+.SH "SEE ALSO"
+.PP
+\fBglob\fR(7),
+\fBpam\fR(8)
+.SH "AUTHOR"
+.PP
Nalin Dahyabhai <nalin@redhat.com>