summaryrefslogtreecommitdiff
path: root/modules/pam_tally
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2003-07-13 18:41:04 +0000
committerSteve Langasek <vorlon@debian.org>2003-07-13 18:41:04 +0000
commit2f36c829822a4b016ba075575c720ad9cb3c6463 (patch)
tree51b4a20becbd7b9d92b6bc0d73565a438525265d /modules/pam_tally
parenteaffa5288f918a542c5322b79975793efc1b3a10 (diff)
Relevant BUGIDs: 643357
Purpose of commit: bugfix Commit summary: --------------- Patch from Sam Hartman to fix handling of module linking on Linux: modules should be linked against libpam if they call any functions from the library, since not all platforms will correctly resolve symbol references otherwise. Also, make sure we use gcc, not ld, when linking, since there's additional linker glue that gcc will pull in for us.
Diffstat (limited to 'modules/pam_tally')
-rw-r--r--modules/pam_tally/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/pam_tally/Makefile b/modules/pam_tally/Makefile
index 1c5106e3..c39970dd 100644
--- a/modules/pam_tally/Makefile
+++ b/modules/pam_tally/Makefile
@@ -65,7 +65,7 @@ ifdef DYNAMIC
$(LIBOBJD): $(LIBSRC)
$(LIBSHARED): $(LIBOBJD)
- $(LD_D) -o $@ $(LIBOBJD)
+ $(LD_D) -o $@ $(LIBOBJD) -L../../libpam -lpam $(NEED_LINK_LIB_C)
$(APPLICATION): $(APPOBJD) $(TITLE).c
$(CC) $(CFLAGS) -o $@ $(APPOBJD) $(LOADLIBES)