summaryrefslogtreecommitdiff
path: root/modules/pam_unix/support.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 21:09:49 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 21:09:49 +0000
commit3387d7584dc78587bb621b0bc4d4e80df576399e (patch)
treee9062f1e9d61115d15a8b5fc97d35567023760c2 /modules/pam_unix/support.c
parent3ab490d6a2dd0b0466c334595f7c3460988e5ffd (diff)
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- Put bigcrypt prototype in own header instead of an external declaration in every single file calling bigcrypt: 2006-06-15 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_unix/bigcrypt.h: New. * modules/pam_unix/Makefile.am: Add bigcrypt.h. * modules/pam_unix/bigcrypt.c: Include bigcrypt.h. * modules/pam_unix/support.c: Include bigcrypt.h, remove own prototype. * modules/pam_unix/bigcrypt_main.c: Include bigcrypt.h, remove own prototype. * modules/pam_unix/pam_unix_passwd.c: Include bigcrypt.h, remove own prototype.
Diffstat (limited to 'modules/pam_unix/support.c')
-rw-r--r--modules/pam_unix/support.c9
1 files changed, 4 insertions, 5 deletions
diff --git a/modules/pam_unix/support.c b/modules/pam_unix/support.c
index cb89eb31..2dc49b80 100644
--- a/modules/pam_unix/support.c
+++ b/modules/pam_unix/support.c
@@ -28,14 +28,13 @@
#include "md5.h"
#include "support.h"
+#include "bigcrypt.h"
#ifdef WITH_SELINUX
#include <selinux/selinux.h>
#define SELINUX_ENABLED is_selinux_enabled()>0
#else
#define SELINUX_ENABLED 0
#endif
-extern char *crypt(const char *key, const char *salt);
-extern char *bigcrypt(const char *key, const char *salt);
/* this is a front-end for module-application conversations */
@@ -527,12 +526,12 @@ static int _unix_run_helper_binary(pam_handle_t *pamh, const char *passwd,
}
/* exec binary helper */
- args[0] = x_strdup(CHKPWD_HELPER);
+ args[0] = strdup(CHKPWD_HELPER);
args[1] = x_strdup(user);
if (off(UNIX__NONULL, ctrl)) { /* this means we've succeeded */
- args[2]=x_strdup("nullok");
+ args[2]=strdup("nullok");
} else {
- args[2]=x_strdup("nonull");
+ args[2]=strdup("nonull");
}
execve(CHKPWD_HELPER, args, envp);