summaryrefslogtreecommitdiff
path: root/modules/pam_unix
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@suse.com>2023-04-06 14:44:07 +0200
committerThorsten Kukuk <5908016+thkukuk@users.noreply.github.com>2023-04-06 16:05:04 +0200
commit4ce09656536911d9048519b8ee18e53353c9cae8 (patch)
tree6553ae931ad895a0cd9d50bdc3a2b074037770dd /modules/pam_unix
parent9c0965b188b972867a62a3b947aa446a3ee3badd (diff)
configure: Disable NIS if header files are missing
configure.ac: Disable NIS if RPC or YP header files are missing modules/pam_unix/support.c: Use HAVE_NIS to check for header file presence modules/pam_unix/pam_unix_passwd.c: Use HAVE_NIS, too
Diffstat (limited to 'modules/pam_unix')
-rw-r--r--modules/pam_unix/pam_unix_passwd.c10
-rw-r--r--modules/pam_unix/support.c2
2 files changed, 3 insertions, 9 deletions
diff --git a/modules/pam_unix/pam_unix_passwd.c b/modules/pam_unix/pam_unix_passwd.c
index d5f5e51f..c3417413 100644
--- a/modules/pam_unix/pam_unix_passwd.c
+++ b/modules/pam_unix/pam_unix_passwd.c
@@ -75,14 +75,8 @@
#ifdef HAVE_NIS
# include <rpc/rpc.h>
-
-# ifdef HAVE_RPCSVC_YP_PROT_H
-# include <rpcsvc/yp_prot.h>
-# endif
-
-# ifdef HAVE_RPCSVC_YPCLNT_H
-# include <rpcsvc/ypclnt.h>
-# endif
+# include <rpcsvc/yp_prot.h>
+# include <rpcsvc/ypclnt.h>
# include "yppasswd.h"
diff --git a/modules/pam_unix/support.c b/modules/pam_unix/support.c
index 23a30498..043273d2 100644
--- a/modules/pam_unix/support.c
+++ b/modules/pam_unix/support.c
@@ -19,7 +19,7 @@
#include <ctype.h>
#include <syslog.h>
#include <sys/resource.h>
-#ifdef HAVE_RPCSVC_YPCLNT_H
+#ifdef HAVE_NIS
#include <rpcsvc/ypclnt.h>
#endif