summaryrefslogtreecommitdiff
path: root/modules
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-02-10 22:33:09 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-02-10 22:33:09 +0000
commit25188cef4bd88edeb68c1bd3c7b54c38e18ad151 (patch)
tree50f1fba939c357213780bcddd599ebb05af59099 /modules
parenta4632111a5e8e107dcbd759f007cbd9cc5147b72 (diff)
Relevant BUGIDs: 131549
Purpose of commit: bugfix Commit summary: --------------- Needed to link lastlog module with -lutil (on some systems).
Diffstat (limited to 'modules')
-rw-r--r--modules/pam_lastlog/Makefile4
-rw-r--r--modules/pam_lastlog/pam_lastlog.c1
2 files changed, 4 insertions, 1 deletions
diff --git a/modules/pam_lastlog/Makefile b/modules/pam_lastlog/Makefile
index 31035a99..333ecd93 100644
--- a/modules/pam_lastlog/Makefile
+++ b/modules/pam_lastlog/Makefile
@@ -10,6 +10,10 @@
include ../../Make.Rules
+ifeq ($(HAVE_LIBUTIL),yes)
+ MODULE_SIMPLE_EXTRALIBS += -lutil
+endif
+
TITLE=pam_lastlog
include ../Simple.Rules
diff --git a/modules/pam_lastlog/pam_lastlog.c b/modules/pam_lastlog/pam_lastlog.c
index 05c3c083..15f83c83 100644
--- a/modules/pam_lastlog/pam_lastlog.c
+++ b/modules/pam_lastlog/pam_lastlog.c
@@ -25,7 +25,6 @@
#include <stdio.h>
#include <string.h>
#include <sys/types.h>
-#define __USE_BSD
#include <syslog.h>
#include <unistd.h>