summaryrefslogtreecommitdiff
path: root/xtests/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2010-10-20 13:11:30 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2010-10-20 13:11:30 +0000
commit5fc7bfece1d98f83ec1ce061508d3ecd8078eb17 (patch)
tree9f604d693f28e7f38b2d7690c58803b266ad6a5f /xtests/Makefile.am
parentecc112f83d3c57ecb9f0b45c63b529853af7ec3f (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- 2010-10-20 Thorsten Kukuk <kukuk@thkukuk.de> * doc/man/Makefile.am: Fix build dependencys of pam_get_authtok.3. * xtests/Makefile.am: Only build xtests if we run xtests.
Diffstat (limited to 'xtests/Makefile.am')
-rw-r--r--xtests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xtests/Makefile.am b/xtests/Makefile.am
index 4168e60e..498a9fca 100644
--- a/xtests/Makefile.am
+++ b/xtests/Makefile.am
@@ -7,7 +7,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
-L$(top_builddir)/libpam_misc -lpam_misc
-CLEANFILES = *~
+CLEANFILES = *~ $(XTESTS)
EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
@@ -47,7 +47,7 @@ NOSRCTESTS = tst-pam_substack1 tst-pam_substack2 tst-pam_substack3 \
tst-pam_substack4 tst-pam_substack5 tst-pam_assemble_line1
-noinst_PROGRAMS = $(XTESTS)
+EXTRA_PROGRAMS = $(XTESTS)
xtests: $(XTESTS) run-xtests.sh
"$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}