summaryrefslogtreecommitdiff
path: root/xtests
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2009-03-09 13:07:34 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2009-03-09 13:07:34 +0000
commit72855d240704c34326c9ae2db56e18f926218b3b (patch)
tree31984c627dd13cdd52597a3a036d0f2f07d73bd3 /xtests
parentc773c1786718c76155074331c7da60e934786da3 (diff)
Relevant BUGIDs:
Purpose of commit: release Commit summary: --------------- 2009-03-09 Thorsten Kukuk <kukuk@thkukuk.de> * release version 1.0.91 * libpam/Makefile.am (libpam_la_LDFLAGS): Bump version number. * xtests/Makefile.am: Add tst-pam_unix4.pamd, tst-pam_unix4.sh and time.conf.
Diffstat (limited to 'xtests')
-rw-r--r--xtests/Makefile.am4
-rwxr-xr-xxtests/run-xtests.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/xtests/Makefile.am b/xtests/Makefile.am
index 83e9dd15..4168e60e 100644
--- a/xtests/Makefile.am
+++ b/xtests/Makefile.am
@@ -14,7 +14,9 @@ EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
tst-pam_dispatch5.pamd \
tst-pam_cracklib1.pamd tst-pam_cracklib2.pamd \
tst-pam_unix1.pamd tst-pam_unix2.pamd tst-pam_unix3.pamd \
+ tst-pam_unix4.pamd \
tst-pam_unix1.sh tst-pam_unix2.sh tst-pam_unix3.sh \
+ tst-pam_unix4.sh \
access.conf tst-pam_access1.pamd tst-pam_access1.sh \
tst-pam_access2.pamd tst-pam_access2.sh \
tst-pam_access3.pamd tst-pam_access3.sh \
@@ -30,7 +32,7 @@ EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
tst-pam_substack5.pamd tst-pam_substack5a.pamd tst-pam_substack5.sh \
tst-pam_assemble_line1.pamd tst-pam_assemble_line1.sh \
tst-pam_pwhistory1.pamd tst-pam_pwhistory1.sh \
- tst-pam_time1.pamd
+ tst-pam_time1.pamd time.conf
XTESTS = tst-pam_dispatch1 tst-pam_dispatch2 tst-pam_dispatch3 \
tst-pam_dispatch4 tst-pam_dispatch5 \
diff --git a/xtests/run-xtests.sh b/xtests/run-xtests.sh
index 73433630..3a890578 100755
--- a/xtests/run-xtests.sh
+++ b/xtests/run-xtests.sh
@@ -27,7 +27,8 @@ for testname in $XTESTS ; do
for cfg in "${SRCDIR}"/$testname*.pamd ; do
install -m 644 $cfg /etc/pam.d/$(basename $cfg .pamd)
done
- if test -x "${SRCDIR}"/$testname.sh ; then
+ if test -f "${SRCDIR}"/$testname.sh ; then
+ test -x "${SRCDIR}"/$testname.sh || chmod 755 "${SRCDIR}"/$testname.sh
"${SRCDIR}"/$testname.sh > /dev/null
else
./$testname > /dev/null