summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/local/pam-auth-update2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b31ddd0..5765e0cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -27,6 +27,10 @@ pam (1.1.2-1) UNRELEASED; urgency=low
compatibility when it's not already set. Closes: #552043.
* debian/local/pam-auth-update: Don't try to pass embedded newlines to
debconf; backslash-escape them instead and use CAPB escape.
+ * debian/local/pam-auth-update: sort additional module options before
+ writing them out, so that we don't wind up with a different config file
+ on every invocation. Thanks to Jim Paris <jim@jtan.com> for the patch.
+ Closes: #594123.
-- Steve Langasek <vorlon@debian.org> Thu, 02 Sep 2010 10:23:42 -0700
diff --git a/debian/local/pam-auth-update b/debian/local/pam-auth-update
index 2f9da0b3..7010cdca 100755
--- a/debian/local/pam-auth-update
+++ b/debian/local/pam-auth-update
@@ -271,7 +271,7 @@ sub merge_one_line
$i--;
}
}
- return $modline . " " . join(' ',@opts,keys(%{$adds})) . "\n";
+ return $modline . " " . join(' ',@opts,sort keys(%{$adds})) . "\n";
}
# return the lines for a given config name, type, and position in the stack