summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches-applied/rhosts_int32_not_bool.patch13
-rw-r--r--debian/patches-applied/series1
3 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7930d207..eeec4d7f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,10 @@ pam (0.99.9.0-1) UNRELEASED; urgency=low
misc_conv_allow_sigint.patch, which have been merged upstream.
* Patch 022_pam_unix_group_time_miscfixes: partially merged upstream;
now is really just "pam_group_miscfixes".
+ * New patch, rhosts_int32_not_bool.patch, to fix a parentheses error in
+ pam_rhosts_auth introduced upstream in 0.99.9.0: we want to cast the
+ result of inet_addr to int32_t, not the result of a boolean *comparison*
+ on inet_addr's result...
* Use a pristine upstream tarball instead of repacking; requires various
changes to debian/rules and debhelper files.
* Replace the Vcs-Svn field with a Vcs-Bzr field; jumping ship from svn,
diff --git a/debian/patches-applied/rhosts_int32_not_bool.patch b/debian/patches-applied/rhosts_int32_not_bool.patch
new file mode 100644
index 00000000..c2a9c3a6
--- /dev/null
+++ b/debian/patches-applied/rhosts_int32_not_bool.patch
@@ -0,0 +1,13 @@
+Index: pam.deb/modules/pam_rhosts/pam_rhosts_auth.c
+===================================================================
+--- pam.deb.orig/modules/pam_rhosts/pam_rhosts_auth.c
++++ pam.deb/modules/pam_rhosts/pam_rhosts_auth.c
+@@ -267,7 +267,7 @@
+
+
+ /* Try for raw ip address first. */
+- if (isdigit(*lhost) && (int32_t)(laddr = inet_addr(lhost) != -1))
++ if (isdigit(*lhost) && (int32_t)(laddr = inet_addr(lhost)) != -1)
+ return (negate*(! (raddr ^ laddr)));
+
+ /* Better be a hostname. */
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 87d53fcf..c674adf5 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -18,4 +18,5 @@ hurd_no_setfsuid
PAM-manpage-section -p2
pam_env_ignore_garbage.patch -p2
pam_tally_audit.patch
+rhosts_int32_not_bool.patch
autoconf.patch