summaryrefslogtreecommitdiff
path: root/Linux-PAM/modules/pam_ftp
diff options
context:
space:
mode:
Diffstat (limited to 'Linux-PAM/modules/pam_ftp')
-rw-r--r--Linux-PAM/modules/pam_ftp/Makefile.am4
-rw-r--r--Linux-PAM/modules/pam_ftp/Makefile.in7
-rw-r--r--Linux-PAM/modules/pam_ftp/pam_ftp.c2
3 files changed, 7 insertions, 6 deletions
diff --git a/Linux-PAM/modules/pam_ftp/Makefile.am b/Linux-PAM/modules/pam_ftp/Makefile.am
index e6d510a1..a4ce03df 100644
--- a/Linux-PAM/modules/pam_ftp/Makefile.am
+++ b/Linux-PAM/modules/pam_ftp/Makefile.am
@@ -13,13 +13,13 @@ securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam
+AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
securelib_LTLIBRARIES = pam_ftp.la
+pam_ftp_la_LIBADD = -L$(top_builddir)/libpam -lpam
TESTS = tst-pam_ftp
diff --git a/Linux-PAM/modules/pam_ftp/Makefile.in b/Linux-PAM/modules/pam_ftp/Makefile.in
index 875a71a1..77e9b3e9 100644
--- a/Linux-PAM/modules/pam_ftp/Makefile.in
+++ b/Linux-PAM/modules/pam_ftp/Makefile.in
@@ -64,7 +64,7 @@ am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(securelibdir)" "$(DESTDIR)$(man8dir)"
securelibLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(securelib_LTLIBRARIES)
-pam_ftp_la_LIBADD =
+pam_ftp_la_DEPENDENCIES =
pam_ftp_la_SOURCES = pam_ftp.c
pam_ftp_la_OBJECTS = pam_ftp.lo
DEFAULT_INCLUDES = -I. -I$(top_builddir)@am__isrc@
@@ -175,6 +175,7 @@ POSUB = @POSUB@
RANLIB = @RANLIB@
SCONFIGDIR = @SCONFIGDIR@
SECUREDIR = @SECUREDIR@
+SED = @SED@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
@@ -251,9 +252,9 @@ XMLS = README.xml pam_ftp.8.xml
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam $(am__append_1)
+AM_LDFLAGS = -no-undefined -avoid-version -module $(am__append_1)
securelib_LTLIBRARIES = pam_ftp.la
+pam_ftp_la_LIBADD = -L$(top_builddir)/libpam -lpam
TESTS = tst-pam_ftp
@ENABLE_REGENERATE_MAN_TRUE@noinst_DATA = README
all: all-am
diff --git a/Linux-PAM/modules/pam_ftp/pam_ftp.c b/Linux-PAM/modules/pam_ftp/pam_ftp.c
index 9c69c108..2c5b9d62 100644
--- a/Linux-PAM/modules/pam_ftp/pam_ftp.c
+++ b/Linux-PAM/modules/pam_ftp/pam_ftp.c
@@ -1,7 +1,7 @@
/* pam_ftp module */
/*
- * $Id: pam_ftp.c,v 1.10 2005/10/04 11:35:18 ldv Exp $
+ * $Id: pam_ftp.c,v 1.11 2007/03/29 13:45:38 t8m Exp $
*
* Written by Andrew Morgan <morgan@linux.kernel.org> 1996/3/11
*