summaryrefslogtreecommitdiff
path: root/modules/pam_debug/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_debug/Makefile.am')
-rw-r--r--modules/pam_debug/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/pam_debug/Makefile.am b/modules/pam_debug/Makefile.am
index 2b3d8613..8aa63056 100644
--- a/modules/pam_debug/Makefile.am
+++ b/modules/pam_debug/Makefile.am
@@ -12,14 +12,14 @@ dist_man_MANS = pam_debug.8
endif
XMLS = README.xml pam_debug.8.xml
dist_check_SCRIPTS = tst-pam_debug
-TESTS = $(dist_check_SCRIPTS)
+TESTS = $(dist_check_SCRIPTS) $(check_PROGRAMS)
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
$(WARN_CFLAGS)
-AM_LDFLAGS = -no-undefined -avoid-version -module
+AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
@@ -27,6 +27,9 @@ endif
securelib_LTLIBRARIES = pam_debug.la
pam_debug_la_LIBADD = $(top_builddir)/libpam/libpam.la
+check_PROGRAMS = tst-pam_debug-retval
+tst_pam_debug_retval_LDADD = $(top_builddir)/libpam/libpam.la
+
if ENABLE_REGENERATE_MAN
dist_noinst_DATA = README
-include $(top_srcdir)/Make.xml.rules