summaryrefslogtreecommitdiff
path: root/debian/patches-applied/007_modules_pam_unix
Commit message (Collapse)AuthorAge
* Refresh patchesSteve Langasek2020-08-12
|
* Refresh patchesSteve Langasek2019-01-24
|
* Consistently include documentation changes in patches, for clean source packageSteve Langasek2019-01-08
|
* Another round of patch refreshingSteve Langasek2019-01-08
|
* Refresh patchesSteve Langasek2019-01-08
|
* debian/patches-applied/{007_modules_pam_unix,055_pam_unix_nullok_secure}:Kees Cook2019-01-08
| | | | drop unneeded no-op change to reduce delta from upstream.
* refresh other patches for new upstream releaseSteve Langasek2019-01-08
|
* further patch fixup to match upstreamSteve Langasek2019-01-08
|
* debian/patches/007_modules_pam_unix: drop compatibility handling ofSteve Langasek2019-01-08
| | | | | 'max=' no-op; use of this option will now log an error, as warned three years ago.
* add a missing commaSteve Langasek2019-01-08
|
* debian/patches-applied/007_modules_pam_unix: fix up patch for newSteve Langasek2019-01-08
| | | | upstream version which now implements minlen=, not min=.
* refresh other patches for new upstream versionSteve Langasek2019-01-08
|
* debian/patches/007_modules_pam_unix: recognize that *all* of the passwordSteve Langasek2019-01-08
| | | | | hashes other than traditional crypt handle passwords >8 chars in length. LP: #356766.
* debian/patches/007_modules_pam_unix: drop divergence from upstreamSteve Langasek2019-01-08
| | | | | | | that treats "0" as a special value in various fields in /etc/shadow, and document this in debian/NEWS. Thanks to Nicolas Fran├žois <nicolas.francois@centraliens.net> for the detailed analysis. Closes: #308229.
* refresh other patches for new upstream releaseSteve Langasek2019-01-08
|
* 007_modules_pam_unix: update the manpage at the same time as the xmlSteve Langasek2019-01-03
| | | | source (grr, autogenerated files in source packages). Closes: #495804.
* * 007_modules_pam_unix: update the documentation to correctly documentSteve Langasek2019-01-03
| | | | the default minimum password length is 6, not 1.
* patch refresh for new upstream versionSteve Langasek2019-01-03
|
* whack-a-mole: fix a syntax error missed when hand-applying the patchSteve Langasek2019-01-03
|
* another fix-up for a hand-merged patchSteve Langasek2019-01-03
|
* refresh patch 007_modules_pam_unix for new upstream version; partiallySteve Langasek2019-01-03
| | | | | superseded upstream, as stripping of hpux-style expiry information from password fields is now supported.
* fix-up commit for grafting svn history onto git historySteve Langasek2019-01-02