summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-03-19 15:35:52 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-03-19 15:35:52 +0100
commit6756e23f945c7a9c685ac4e8b06eae052f52b574 (patch)
treeced261e2433e6641d06529d3ff586c970f456d7e
parente98b9f679619c4da2066697d3883a091736a37a0 (diff)
Rename static-linux -> linux.
-rw-r--r--Makefile2
-rw-r--r--static-linux/Dockerfile35
-rw-r--r--static-linux/Makefile12
-rwxr-xr-xstatic-linux/make_deb.sh50
4 files changed, 1 insertions, 98 deletions
diff --git a/Makefile b/Makefile
index d5c4c3e31..2f6145da7 100644
--- a/Makefile
+++ b/Makefile
@@ -32,7 +32,7 @@ dist: man/pandoc.1
stack setup && stack test && cd .. && rm -rf "pandoc-${version}"
debpkg: man/pandoc.1
- make -C static-linux
+ make -C linux
macospkg: man/pandoc.1
./macos/make_macos_package.sh
diff --git a/static-linux/Dockerfile b/static-linux/Dockerfile
deleted file mode 100644
index c73b17622..000000000
--- a/static-linux/Dockerfile
+++ /dev/null
@@ -1,35 +0,0 @@
-# USE ALPINE LINUX
-FROM alpine:edge
-RUN echo "https://s3-us-west-2.amazonaws.com/alpine-ghc/8.0" >> /etc/apk/repositories
-ADD https://raw.githubusercontent.com/mitchty/alpine-ghc/master/mitch.tishmack%40gmail.com-55881c97.rsa.pub \
- /etc/apk/keys/mitch.tishmack@gmail.com-55881c97.rsa.pub
-RUN apk update
-RUN apk add alpine-sdk git ca-certificates ghc cabal stack zlib-dev \
- dpkg fakeroot sed gawk grep
-RUN stack update
-RUN stack config set system-ghc --global true
-RUN mkdir -p /etc/stack
-RUN echo "build: { split-objs: true }" > /etc/stack/config.yaml
-RUN mkdir -p /usr/src/
-WORKDIR /usr/src/
-RUN git clone https://github.com/jgm/pandoc
-WORKDIR /usr/src/pandoc
-RUN stack install --local-bin-path /usr/bin hsb2hs
-RUN stack install --stack-yaml stack.pkg.yaml --only-dependencies \
- --flag 'pandoc:embed_data_files' \
- --test --ghc-options '-O2 -optc-Os -optl-static -fPIC' \
- pandoc pandoc-citeproc
-COPY make_deb.sh .
-CMD git pull && \
- git checkout -b work $TREE && \
- export VERSION=`grep '^Version:' pandoc.cabal | awk '{print $$2;}'` && \
- stack install --stack-yaml stack.pkg.yaml \
- --local-bin-path /artifacts --flag 'pandoc:embed_data_files' \
- --test --ghc-options '-O2 -optc-Os -optl-static -fPIC' \
- pandoc pandoc-citeproc && \
- bash make_deb.sh && \
- cd /artifacts && \
- mkdir pandoc-$VERSION && \
- mv pandoc pandoc-citeproc pandoc-$VERSION/ && \
- tar cvzf pandoc-$VERSION.tgz pandoc-$VERSION && \
- rm -r pandoc-$VERSION
diff --git a/static-linux/Makefile b/static-linux/Makefile
deleted file mode 100644
index 8c359da7b..000000000
--- a/static-linux/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-TREE?=HEAD
-ARTIFACTS=`pwd`/artifacts
-
-build:
- mkdir -p $(ARTIFACTS)
- docker build -t alpine-pandoc .
- docker run --env TREE=$(TREE) -v $(ARTIFACTS):/artifacts alpine-pandoc
-
-setup:
- docker pull alpine:edge
-
-.PHONY: build setup
diff --git a/static-linux/make_deb.sh b/static-linux/make_deb.sh
deleted file mode 100755
index f6abece68..000000000
--- a/static-linux/make_deb.sh
+++ /dev/null
@@ -1,50 +0,0 @@
-MACHINE=$(uname -m)
-case "$MACHINE" in
- x86_64) ARCHITECTURE=amd64;;
- i686) ARCHITECTURE=i386;;
- i386) ARCHITECTURE=i386;;
-esac
-
-ARTIFACTS=/artifacts
-
-VERSION=$(grep -e '^Version' pandoc.cabal | awk '{print $2}')
-DEBPKGVER=${DEBPKGVER:-1}
-DEBVER=$VERSION-$DEBPKGVER
-BASE=pandoc-$DEBVER-$ARCHITECTURE
-DIST=`pwd`/$BASE
-DEST=$DIST/usr
-COPYRIGHT=$DEST/share/doc/pandoc/copyright
-
-PATH=$ARTIFACTS:$PATH
-PANDOC_CITEPROC_VERSION=`pandoc-citeproc --version | awk '{print $2;}'`
-
-mkdir -p $DEST/bin
-mkdir -p $DEST/share/man/man1
-mkdir -p $DEST/share/doc/pandoc
-
-make man/pandoc.1
-
-mkdir -p $DEST/share/doc/pandoc-citeproc
-find $DIST -type d | xargs chmod 755
-cp $ARTIFACTS/pandoc $DEST/bin/
-cp $ARTIFACTS/pandoc-citeproc $DEST/bin/
-cp man/pandoc.1 $DEST/share/man/man1/pandoc.1
-pandoc-citeproc --man > $DEST/share/man/man1/pandoc-citeproc.1
-gzip -9 $DEST/share/man/man1/pandoc.1
-gzip -9 $DEST/share/man/man1/pandoc-citeproc.1
-
-cp COPYRIGHT $COPYRIGHT
-echo "" >> $COPYRIGHT
-echo "pandoc-citeproc" >> $COPYRIGHT
-pandoc-citeproc --license >> $COPYRIGHT
-
-INSTALLED_SIZE=$(du -k -s $DEST | awk '{print $1}')
-mkdir $DIST/DEBIAN
-perl -pe "s/VERSION/$DEBVER/" deb/control.in | \
- perl -pe "s/ARCHITECTURE/$ARCHITECTURE/" | \
- perl -pe "s/INSTALLED_SIZE/$INSTALLED_SIZE/" \
- > $DIST/DEBIAN/control
-
-fakeroot dpkg-deb --build $DIST
-rm -rf $DIST
-cp $BASE.deb /artifacts/