summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-07-14 06:28:09 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-07-14 06:28:09 +0000
commit9a96429a1a018803c8b1af6d9a9300d346b53b3c (patch)
tree59e242cc5fcf1b35da07ca555bb8eee5d88df268
parent532dd43139d4056bc83b7994bd68b965d07e750b (diff)
Revamped website.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@699 788f1e2b-df1e-0410-8736-df70ead52e1b
-rw-r--r--Makefile22
-rw-r--r--web/Makefile25
-rw-r--r--web/demos4
-rw-r--r--web/footer.html4
-rw-r--r--web/index.txt169
-rw-r--r--web/pandoc.css64
6 files changed, 193 insertions, 95 deletions
diff --git a/Makefile b/Makefile
index c3f2eb44a..93c2bc130 100644
--- a/Makefile
+++ b/Makefile
@@ -368,30 +368,14 @@ website: $(MAIN) html
( \
mkdir $(web_dest); \
cp -r html $(web_dest)/doc; \
- cp $(web_src)/*.css $(web_dest)/; \
- cp $(web_src)/css $(web_dest)/; \
+ cp $(web_src)/* $(web_dest)/; \
sed -e 's#@PREFIX@#$(PREFIX)#g' $(osx_src)/Welcome > \
$(web_dest)/osx-notes.txt; \
- sed -e '/^ --.*/d' -e 's#^# #g' changelog | \
- sed -e 's/ \(pandoc (.*\)/## \1/g' > \
- $(web_dest)/changelog.txt; \
+ cp changelog $(web_dest)/ ; \
cp README $(web_dest)/ ; \
cp INSTALL $(web_dest)/ ; \
cp $(MANDIR)/man1/pandoc.1.md $(web_dest)/ ; \
- sed -e 's/@TARBALL_NAME@/$(tarball_name)/g' $(web_src)/index.txt | \
- sed -e 's/@OSX_DMG_NAME@/$(osx_dmg_name)/g' | \
- sed -e 's/@WINDOWS_PKG_NAME@/$(win_pkg_name)/g' | \
- sed -e 's/@VERSION@/$(VERSION)/g' > $(web_dest)/index.txt; \
- cp $(web_src)/features.txt $(web_dest)/ ; \
- cp $(web_src)/myheader.tex $(web_dest)/ ; \
- cp $(web_src)/S5DEMO $(web_dest)/ ; \
- cp $(web_src)/header.html $(web_dest)/ ; \
- cp $(web_src)/footer.html $(web_dest)/ ; \
- cp $(web_src)/mkdemos.pl $(web_dest)/ ; \
- cp $(web_src)/demos $(web_dest)/ ; \
- cp $(web_src)/docbook.css $(web_dest)/ ; \
- cp $(web_src)/config.xsl $(web_dest)/ ; \
- cp $(web_src)/Makefile $(web_dest)/ ; \
+ cp $(MANDIR)/man1/*.1 $(web_dest)/ ; \
PANDOC_PATH=$(shell pwd) make -C $(web_dest) ; \
) || { rm -rf $(web_dest); exit 1; }
diff --git a/web/Makefile b/web/Makefile
index ebe5ad7cc..708332781 100644
--- a/web/Makefile
+++ b/web/Makefile
@@ -1,8 +1,6 @@
-ALL := index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
+ALL := index.html osx-notes.html README.html INSTALL.html examples.html pandoc1.html markdown2pdf1.html html2markdown1.html hsmarkdown1.html
PANDOC_PATH ?= $(dir $(shell which pandoc))
-MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -B header.html -A footer.html -H css
-PANDOC_DEPS = header.html footer.html css
-
+MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -c pandoc.css -A footer.html
all : $(ALL)
.PHONY: clean
@@ -17,14 +15,23 @@ examples.txt : $(PANDOC_DEPS) mkdemos.pl config.xsl S5DEMO README demos
do highlight -u utf-8 --style emacs $$file > $$file.html; \
done
-%.html : %.txt $(PANDOC_DEPS)
- $(MAKEPAGE) $< > $@
+index.html : index.txt
+ $(MAKEPAGE) --toc $< > $@
+
+README.html : README
+ $(MAKEPAGE) --toc $< > $@
-%.html : % $(PANDOC_DEPS)
+INSTALL.html : INSTALL
+ $(MAKEPAGE) --toc $< > $@
+
+%.html : %.txt
$(MAKEPAGE) $< > $@
-changelog.html : changelog.txt $(PANDOC_DEPS)
- $(MAKEPAGE) -T "Pandoc changelog" $< > $@
+%1.html : %.1
+ groff -man -T html $< > $@
+
+%.html : %
+ $(MAKEPAGE) $< > $@
upload :
sitecopy --update macfarlane
diff --git a/web/demos b/web/demos
index 90371af0a..fe12bf35b 100644
--- a/web/demos
+++ b/web/demos
@@ -11,9 +11,9 @@ click on the name of the output file:
@ pandoc -s README -o example2.html
-3. HTML with smart quotes, table of contents, CSS, and custom header and footer:
+3. HTML with smart quotes, table of contents, CSS, and custom footer:
-@ pandoc -s -S --toc -c main.css -B header.html -A footer.html README -o example3.html
+@ pandoc -s -S --toc -c pandoc.css -A footer.html README -o example3.html
4. LaTeX:
diff --git a/web/footer.html b/web/footer.html
index 16dd8fffb..8798c2562 100644
--- a/web/footer.html
+++ b/web/footer.html
@@ -1,4 +1,4 @@
+<div id="footer">
+ &copy; 2006-2007 <a href="http://sophos.berkeley.edu/macfarlane/">John MacFarlane</a>
</div>
-
-
diff --git a/web/index.txt b/web/index.txt
index c49924b52..2fc17d9d5 100644
--- a/web/index.txt
+++ b/web/index.txt
@@ -1,81 +1,116 @@
% Pandoc
+# Overview
+
Pandoc is a [Haskell] library for converting from one markup format
to another, and a command-line tool that uses this library. It can read
[markdown] and (subsets of) [reStructuredText], [HTML], and [LaTeX],
and it can write [markdown], [reStructuredText], [HTML], [LaTeX], [RTF],
-[DocBook XML], [groff man], and [S5] HTML slide shows. Pandoc's version
-of markdown contains some enhancements, like footnotes and embedded LaTeX.
-
-In contrast to existing tools for converting markdown to HTML, which
-use regex substitutions, Pandoc has a modular design: it consists of a
-set of readers, which parse text in a given format and produce a native
-representation of the document, and a set of writers, which convert
-this native representation into a target format. Thus, adding an input
-or output format requires only adding a reader or writer.
-
-For more information, see the [README](README.html) file.
-
-Pandoc is free software, released under the [GPL].
-
-**Source distribution:** [`@TARBALL_NAME@`].
-To install, unpack the archive and follow the instructions in the
-[INSTALL](INSTALL.html) file. You'll need the [GHC] Haskell compiler,
-version 6.6 or higher.
-
-**MacOS X binary package:** [`@OSX_DMG_NAME@`].
-To install, just double-click the package icon in the disk
-image. See the [installation notes](osx-notes.html) for important
-information about setting your `PATH`. Note: This package was
-compiled on a G4 Mac; it will also work on an Intel Mac via emulation.
-
-**Windows binary package:** [`@WINDOWS_PKG_NAME@`].
-The zip file contains the `pandoc.exe` command-line program (which
-you should extract from the zip archive and put somewhere in your
-PATH). See the included file `README-WINDOWS.txt` for instructions
-on using the program. Note: If you use [Cygwin], we recommend that
-you compile Pandoc from source. This will give you access to the
-wrapper scripts `markdown2pdf`, `html2markdown`, and `hsmarkdown`,
-which are not included in the Windows binary package.
-
-[`@TARBALL_NAME@`]: http://code.google.com/p/pandoc/downloads/detail?name=@TARBALL_NAME@
- "Download source tarball from Pandoc's Google Code site"
-[`@OSX_DMG_NAME@`]: http://code.google.com/p/pandoc/downloads/detail?name=@OSX_DMG_NAME@
- "Download Mac OS X disk image from Pandoc's Google Code site"
-[`@WINDOWS_PKG_NAME@`]: http://code.google.com/p/pandoc/downloads/detail?name=@WINDOWS_PKG_NAME@
- "Download Windows zip file from Pandoc's Google Code site"
-[Cygwin]: http://www.cygwin.com/
- "Cygwin - a linux-like environment for Windows"
-
-**Debian linux package:** [`pandoc_0.3_i386.deb`] (thanks to Recai Oktaş).
-To install, download the file and type:
-
- sudo dpkg -i pandoc_0.3_i386.deb
-
-[`pandoc_0.3_i386.deb`]: http://people.debian.org/~roktas/packages/pandoc_0.3_i386.deb
-
-**FreeBSD port:** <http://www.freshports.org/textproc/pandoc/>
+[DocBook XML], [groff man], and [S5] HTML slide shows.
+
+- A real markdown parser, not based on regex substitutions.
+- Modular design, using separate writers and readers for each
+ supported format, for easy extensibility.
+- [More accurate] and [faster], in many cases, than `Markdown.pl`.
+- Multiple output formats--HTML, Docbook XML, LaTeX, reStructuredText,
+ RTF, groff man pages, S5 slide shows--generated natively,
+ with no XSLT postprocessing.
+- Converts *to* markdown from HTML, LaTeX, and reStructuredText.
+- Unicode support.
+- Optional "smart" quotes, dashes, and ellipses.
+- Document metadata (title, author, date).
+- Inline LaTeX math and LaTeX commands.
+- [ASCIIMathML] support for equations in HTML.
+- Footnotes, tables, and definition lists in all output formats.
+- Automatically generated tables of contents.
+- Compatibility mode to turn off syntax entensions and emulate
+ `Markdown.pl`.
+- Convenient wrapper scripts:
+ + `html2markdown` makes it easy to produce a markdown version
+ of any web page.
+ + `markdown2pdf` converts markdown to PDF in one step.
+ + `hsmarkdown` is a drop-in replacement for `Markdown.pl`.
+- Multi-platform: runs on Windows, MacOS X, Linux, Unix.
+- Free software, released under the [GPL].
+
+To see what pandoc can do, see the [demonstration page](examples.html).
+
+# Documentation
+
+- [User's Guide](README.html)
+- [Demonstrations](examples.html)
+- Man pages
+ - [`pandoc(1)`](pandoc1.html)
+ - [`markdown2pdf(1)`](markdown2pdf1.html)
+ - [`html2markdown(1)`](html2markdown1.html)
+ - [`hsmarkdown(1)`](hsmarkdown1.html)
+- [Library documentation](doc/index.html) (for Haskell programmers)
+- [Instructions for installing from source](INSTALL.html)
+- [Changelog](changelog)
+
+# Downloads
+
+- [Source tarball].
+ To install, unpack the archive and follow the instructions in the
+ [INSTALL](INSTALL.html) file. You'll need the [GHC] Haskell compiler,
+ version 6.6 or higher.
+
+- [MacOS X binary package].
+ To install, just double-click the package icon in the disk
+ image. See the [installation notes](osx-notes.html) for important
+ information about setting your `PATH`. Note: This package was
+ compiled on a G4 Mac; it will also work on an Intel Mac via emulation.
+
+- [Windows binary package].
+ The zip file contains the `pandoc.exe` command-line program (which
+ you should extract from the zip archive and put somewhere in your
+ PATH). See the included file `README-WINDOWS.txt` for instructions
+ on using the program. Note: If you use [Cygwin], we recommend that
+ you compile Pandoc from source. This will give you access to the
+ wrapper scripts `markdown2pdf`, `html2markdown`, and `hsmarkdown`,
+ which are not included in the Windows binary package.
+
+- [FreeBSD port].
+
+- [Debian linux package] (thanks to Recai Oktaş).
+ To install, download the file and type:
+
+ sudo dpkg -i pandoc_0.3_i386.deb
+
+# Code repository
+
+Pandoc has a publicly accesible subversion repository at Google
+Code (<http://code.google.com/p/pandoc>). To check out the latest,
+bleeding-edge source code:
+
+ svn checkout http://pandoc.googlecode.com/svn/trunk/ pandoc
+
+# Reporting bugs
+
+You may view existing bug reports and submit new ones at
+<http://code.google.com/p/pandoc/issues/list>.
-**Repository:** Pandoc has a publicly accesible subversion repository
-at Google Code (<http://code.google.com/p/pandoc>). To check out the
-latest, bleeding-edge source code:
+# Mailing lists
- svn checkout http://pandoc.googlecode.com/svn/trunk/ pandoc
+- [pandoc-announce]: Announcements of new releases only.
+- [pandoc-discuss]: General discussion of pandoc.
-**Bugs:** You may view existing bug reports and submit new ones at
-<http://code.google.com/p/pandoc/issues/list>.
+# News
-**Announcements list:** If you'd like to receive announcements of
-new releases of Pandoc, you may subscribe to the [pandoc-announce
-mailing list].
+- Version 0.4 released (?? July 2007). Features:
+ - list
+ - of
+ - features
-**API:** You can browse the API documentation for the Pandoc Haskell
-libraries [here](doc/index.html).
+# Disclaimer
This is an early, "alpha" release. It carries no warranties of any
kind.
-[pandoc-announce mailing list]: http://groups.google.com/group/pandoc-announce
+[More accurate]: http://code.google.com/p/pandoc/wiki/PandocVsMarkdownPl
+[faster]: http://code.google.com/p/pandoc/wiki/Benchmarks
+[ASCIIMathML]: http://www1.chapman.edu/~jipsen/mathml/asciimath.html
+
[John MacFarlane]: http://sophos.berkeley.edu/macfarlane/
[markdown]: http://daringfireball.net/projects/markdown/
[reStructuredText]: http://docutils.sourceforge.net/docs/ref/rst/introduction.html
@@ -88,4 +123,12 @@ kind.
[Haskell]: http://www.haskell.org/
[GHC]: http://www.haskell.org/ghc/
[GPL]: http://www.gnu.org/copyleft/gpl.html
+[Source tarball]: http://code.google.com/p/pandoc/downloads/detail?name=pandoc-0.4.tar.gz "Download source tarball from Pandoc's Google Code site"
+[MacOS X binary package]: http://code.google.com/p/pandoc/downloads/detail?name=pandoc-0.4.dmg "Download Mac OS X disk image from Pandoc's Google Code site"
+[Windows binary package]: http://code.google.com/p/pandoc/downloads/detail?name=pandoc-0.4.zip "Download Windows zip file from Pandoc's Google Code site"
+[Cygwin]: http://www.cygwin.com/ "Cygwin - a linux-like environment for Windows"
+[Debian linux package]: http://people.debian.org/~roktas/packages/pandoc_0.3_i386.deb
+[FreeBSD port]: http://www.freshports.org/textproc/pandoc/
+[pandoc-announce]: http://groups.google.com/group/pandoc-announce
+[pandoc-discuss]: http://groups.google.com/group/pandoc-discuss
diff --git a/web/pandoc.css b/web/pandoc.css
new file mode 100644
index 000000000..fc0e042be
--- /dev/null
+++ b/web/pandoc.css
@@ -0,0 +1,64 @@
+body {
+ margin: auto;
+ padding-right: 1em;
+ padding-left: 1em;
+ max-width: 44em;
+ border-left: 1px solid black;
+ border-right: 1px solid black;
+ color: black;
+ font-family: Verdana, sans-serif;
+ font-size: 100%;
+ line-height: 140%;
+ color: #333;
+}
+pre {
+ border: 1px dotted gray;
+ background-color: #ececec;
+ color: #1111111;
+ padding: 0.5em;
+}
+code {
+ font-family: monospace;
+ font-size: 110%;
+}
+h1, h2, h3, h4, h5 { font-family: verdana;
+ font-weight: bold;
+ border-bottom: 1px dotted black;
+ color: #7a5ada; }
+h1 {
+ font-size: 130%;
+}
+
+h2 {
+ font-size: 110%;
+}
+
+h3 {
+ font-size: 95%;
+}
+
+h4 {
+ font-size: 90%;
+ font-style: italic;
+}
+
+h5 {
+ font-size: 90%;
+ font-style: italic;
+}
+
+h1.title {
+ font-size: 200%;
+ font-weight: bold;
+ padding-top: 0.2em;
+ padding-bottom: 0.2em;
+ text-align: left;
+ border: none;
+}
+
+#footer {
+ padding-top: 1em;
+ font-size: 70%;
+ color: gray;
+ text-align: center;
+}