summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-02 05:02:01 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-02 05:02:01 +0000
commitbcc608f3fdee8a7d6258d87ee41ff72601a6026a (patch)
tree212acbdbbe70a8b8025d15fa4e9c54f76b6536cf
parent339fcbbb4642014426c94381bdacfa2fe2326536 (diff)
Fixed a bug in website generation, which only worked if 'pandoc'
and the wrappers had been installed. git-svn-id: https://pandoc.googlecode.com/svn/trunk@402 788f1e2b-df1e-0410-8736-df70ead52e1b
-rw-r--r--Makefile2
-rw-r--r--web/mkdemos.sh3
2 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3414ff62f..ba215d716 100644
--- a/Makefile
+++ b/Makefile
@@ -374,7 +374,7 @@ $(web_dest)/: $(MAIN) html
cp $(web_src)/S5DEMO $(web_dest)/ ; \
cp $(web_src)/header.html $(web_dest)/ ; \
cp $(web_src)/footer.html $(web_dest)/ ; \
- sh $(web_src)/mkdemos.sh $(web_dest) $(abspath .) | \
+ sh $(web_src)/mkdemos.sh $(web_dest) $(shell pwd) | \
$(make_page) > $(web_dest)/examples.html; \
) || { rm -rf $(web_dest); exit 1; }
diff --git a/web/mkdemos.sh b/web/mkdemos.sh
index b3e344413..11628bb04 100644
--- a/web/mkdemos.sh
+++ b/web/mkdemos.sh
@@ -27,7 +27,6 @@ set -- $EXAMPLES
IFS=$oldifs
cd $DEST
-PATH=$PROGPATH:$PATH
echo '% Pandoc examples
@@ -44,6 +43,6 @@ for command in "$@"; do
output=$(echo $command | sed -e 's/.*-o \(.*\)/\1/')
echo "1. <code>$firstpart <a href=\""$input"\" title=\""View input file"\">$input</a> -o <a href=\""$output"\" title=\""View pandoc output"\">$output</a></code>"
echo $command >&2
- result=$($command) # run the command and create output file
+ result=$(PATH=$PROGPATH:$PATH $command) # run the command and create output file
done