summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-11-15 08:17:09 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2015-11-15 08:17:09 -0800
commit07e1234c3bbedea38793891215006c0e03d6582c (patch)
treed8eb78edf5b61a9790aa4e454903942f69b963b4 /Makefile
parent9ebd601d89221753846259b9deea9266d0dce548 (diff)
Added 'make changes' target.
This copies to osx clipboard a github-markdown version of the changes from the latest release in the changelog.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e4c792b2a..aa11fd363 100644
--- a/Makefile
+++ b/Makefile
@@ -23,6 +23,9 @@ test:
bench:
cabal bench
+changes:
+ pandoc --filter extract-changes.hs changelog -t markdown_github | pbcopy
+
install: full
cabal copy
cabal register
@@ -58,4 +61,4 @@ download_stats:
clean:
cabal clean
-.PHONY: deps quick full install clean test bench osxpkg dist prof download_stats
+.PHONY: deps quick full install clean test bench changes osxpkg dist prof download_stats