summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-08-31 06:25:00 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-08-31 06:25:00 +0000
commit0c09f4c5296661dfaf920e011cca115d4f570c61 (patch)
tree8e48889c01669b09f348b6adf15e419c683cd10e /Makefile
parent89ec99c383e07fced1bf15989da6bcfd557ccec7 (diff)
Makefile: Get VERSION from cabal file, not Main.hs.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@973 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a074a4de1..96a84862a 100644
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,7 @@ CONFIGURE := configure
#-------------------------------------------------------------------------------
NAME := $(shell sed -ne 's/^[Nn]ame:[[:space:]]*//p' $(CABAL))
THIS := $(shell echo $(NAME) | tr A-Z a-z)
-VERSION := $(shell sed -ne 's/^version[[:space:]]*=[[:space:]]*"\([^"]*\)"/\1/p' $(SRCDIR)/Main.hs)
+VERSION := $(shell sed -ne 's/^[Vv]ersion:[[:space:]]*//p' $(CABAL))
RELNAME := $(THIS)-$(VERSION)
EXECSBASE := $(shell sed -ne 's/^[Ee]xecutable:[[:space:]]*//p' $(CABAL))