summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-03-04 12:49:14 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-03-04 12:49:14 +0100
commit0edfbf1478950d645ece19ced0156771ba16ebb6 (patch)
treeb0598dc9e2ced115952982460a9884e39bc20b51 /Makefile
parent17ce81306043b14a67f3af40f77e5f860ffc4719 (diff)
Added 'make refactor' using hlint, stylish-haskell.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d89f52984..343fd8f4f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
version?=$(shell grep '^Version:' pandoc.cabal | awk '{print $$2;}')
pandoc=$(shell find dist -name pandoc -type f -exec ls -t {} \; | head -1)
+sourcefiles=$(shell find pandoc.hs src test -name '*.hs')
BRANCH?=master
quick:
@@ -15,6 +16,9 @@ test:
bench:
stack bench
+refactor:
+ ./tools/refactor.sh $(sourcefiles)
+
changes_github:
pandoc --filter extract-changes.hs changelog -t markdown_github | sed -e 's/\\#/#/g' | pbcopy
@@ -53,4 +57,4 @@ download_stats:
clean:
stack clean
-.PHONY: deps quick full install clean test bench changes_github macospkg dist prof download_stats
+.PHONY: deps quick full install clean test bench changes_github macospkg dist prof download_stats refactor