summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-09-03 16:57:17 +0000
committerroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-09-03 16:57:17 +0000
commit1142c8872771c6cae84c7638c8f280b00f72d15d (patch)
treebeb03d4b5dc7aae7d257ac10535483f97cb87909 /Makefile
parentb13e696c93535c7835201ee34432ca73a11e04aa (diff)
* The previous fix was wrong. Apply a proper fix and cross the fingers. :-)
+ On configure, compile 'Setup.hs' to 'setup' and use 'setup' as the build command instead of 'runhaskell', which, on some platforms (such as s390, alpha, m68k), throws the following error: runhaskell Setup.hs configure --prefix=/usr ghc-6.6.1: not built for interactive use This causes a serious FTBFS bug. Closes: #440668 (from Debian BTS). + Setup.hs: revert changes. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1005 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 7a13a1628..67e227958 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ MANDIR := man
TESTDIR := tests
BUILDDIR := dist
BUILDCONF := .setup-config
-BUILDCMD := ./Setup.hs
+BUILDCMD := ./setup
BUILDVARS := vars
CONFIGURE := configure
@@ -118,9 +118,10 @@ $(WRAPPERS): %: $(SRCDIR)/wrappers/%.in $(SRCDIR)/wrappers/*.sh
@$(generate-shell-script)
.PHONY: configure
-cleanup_files+=$(BUILDDIR) $(BUILDCONF) $(BUILDVARS)
+cleanup_files+=Setup.hi Setup.o $(BUILDCMD) $(BUILDDIR) $(BUILDCONF) $(BUILDVARS)
configure: $(BUILDCONF) templates
$(BUILDCONF): $(CABAL)
+ ghc -package Cabal Setup.hs -o $(BUILDCMD)
$(BUILDCMD) configure --prefix=$(PREFIX)
# Make configuration time settings persistent (definitely a hack).
@echo "PREFIX?=$(PREFIX)" >$(BUILDVARS)