summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-10-07 21:43:44 +0000
committerroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-10-07 21:43:44 +0000
commit175ddc3f6e6fec97ffe51b943c02079818be8721 (patch)
tree5cf66ffe5ebf6542bc9201e1f018e6cb28a8677e /Makefile
parentea0d5663be157e623f5c5fb13c120f4f1c3eeb33 (diff)
Makefile:
- New variables to make use in debian/rules: DATADIR, DOCDIR. Cabal uses $prefix/pandoc-$VERSION/doc for the documentation files, where as the Debian package uses $prefix/doc/pandoc. We need these variables to resolve the conflict. debian/rules: - Set and export DATADIR, DOCDIR which controls the installation of document files at install-program target. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1045 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 742b86129..e3129aa39 100644
--- a/Makefile
+++ b/Makefile
@@ -46,6 +46,8 @@ destdir :=
# Fallback to defaults but allow to get the values from environment.
PREFIX ?= $(prefix)
DESTDIR ?= $(destdir)
+DATADIR ?= $(PKGID)
+DOCDIR ?= $(PKGID)/doc
#-------------------------------------------------------------------------------
# Installation paths
@@ -54,8 +56,8 @@ DESTPATH := $(DESTDIR)$(PREFIX)
BINPATH := $(DESTPATH)/bin
DATAPATH := $(DESTPATH)/share
MANPATH := $(DATAPATH)/man
-PKGDATAPATH := $(DATAPATH)/$(PKGID)
-PKGDOCPATH := $(PKGDATAPATH)/doc
+PKGDATAPATH := $(DATAPATH)/$(DATADIR)
+PKGDOCPATH := $(DATAPATH)/$(DOCDIR)
#-------------------------------------------------------------------------------
# Generic Makefile variables
@@ -190,7 +192,7 @@ uninstall-program: uninstall-exec uninstall-doc
.PHONY: install-all uninstall-all
# Full installation through Cabal: main + wrappers + user docs + lib + lib docs
-install-all: install-program
+install-all: build-all install-program
destdir=$(DESTDIR); \
# Older Cabal versions have no '--destdir' option.
if $(BUILDCMD) copy --help | grep -q '\-\-destdir'; then \