summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-11-02 03:30:47 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-11-02 03:30:47 +0000
commit309a15010c90ef8938c1106118421519798908ee (patch)
tree08b0859461322c3ef50d0d38a555f0f6902d9f1b /Makefile
parentdd297dda0abf5c19243e7570fe153fefa338e166 (diff)
Changes related to osx packaging:
+ Simplified osx-dmg target, which need not be built as root. + Made osx-pkg and osx-pkg-prep non-.PHONY, plus a few other minor changes to make the dependencies work correctly. + Removed \< from the sed regex in cabalize; this is not support in BSD sed. + Changed path information in osx/Welcome and message in uninstall-pandoc. git-svn-id: https://pandoc.googlecode.com/svn/trunk@67 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index ddc66c2aa..db462a873 100644
--- a/Makefile
+++ b/Makefile
@@ -164,14 +164,13 @@ uninstall-all: uninstall-exec uninstall-doc uninstall-lib-doc
install: install-program
uninstall: uninstall-program
-.PHONY: osx-pkg osx-pkg-prep
osx_dest:=osx-pkg-tmp
osx_src:=osx
doc_more:=README.rtf LICENSE.rtf $(osx_src)/Welcome.rtf
osx_pkg_name:=Pandoc_$(VERSION).pkg
cleanup_files+=$(osx_dest) $(doc_more) $(osx_pkg_name)
osx-pkg-prep: $(osx_dest)
-$(osx_dest): $(doc_more) $(BINS)
+$(osx_dest)/: $(doc_more) $(BINS)
-rm -rf $(osx_dest)
$(INSTALL) -d $(osx_dest)
DESTDIR=$(osx_dest)/Package_root $(MAKE) install-program
@@ -179,8 +178,8 @@ $(osx_dest): $(doc_more) $(BINS)
find $(osx_dest) -type f -regex ".*bin/.*" | xargs chmod +x
find $(osx_dest) -type f -regex ".*bin/$(THIS)" | xargs $(STRIP)
$(INSTALL) -d $(osx_dest)/Resources
- mv README.rtf $(osx_dest)/Resources/ReadMe.rtf
- mv LICENSE.rtf $(osx_dest)/Resources/License.rtf
+ cp README.rtf $(osx_dest)/Resources/ReadMe.rtf
+ cp LICENSE.rtf $(osx_dest)/Resources/License.rtf
sed -e 's#@PREFIX@#$(PREFIX)#g' $(osx_src)/Welcome.rtf > $(osx_dest)/Resources/Welcome.rtf
sed -e 's/@VERSION@/$(VERSION)/g' $(osx_src)/Info.plist > $(osx_dest)/Info.plist
cp $(osx_src)/Description.plist $(osx_dest)/
@@ -189,19 +188,20 @@ osx-pkg: osx-pkg-prep
echo "Root permissions needed to create OSX package!"; \
exit 1; \
fi
- find $(osx_dest) -type f | xargs chown root:wheel
+ find $(osx_dest) | xargs chown root:wheel
PackageMaker -build -p $(osx_pkg_name) \
-f $(osx_dest)/Package_root \
-r $(osx_dest)/Resources \
-i $(osx_dest)/Info.plist \
-d $(osx_dest)/Description.plist
+ chgrp admin $(osx_pkg_name)
-rm -rf $(osx_dest)
-.PHONY: osx-dmg osx-dmg-prep
+.PHONY: osx-dmg
osx_dmg_name:=Pandoc.dmg
osx_dmg_volume:="Pandoc $(VERSION)"
cleanup_files+=$(osx_dmg_name)
-osx-dmg-prep: $(osx_pkg_name)
+osx-dmg: $(osx_pkg_name)
-rm -f $(osx_dmg_name)
hdiutil create $(osx_dmg_name) -size 05m -fs HFS+ -volname $(osx_dmg_volume)
dev_handle=`hdid $(osx_dmg_name) | grep Apple_HFS | \
@@ -211,12 +211,6 @@ osx-dmg-prep: $(osx_pkg_name)
hdiutil convert $(osx_dmg_name) -format UDZO -o Pandoc.udzo.dmg
-rm -f $(osx_dmg_name)
mv Pandoc.udzo.dmg $(osx_dmg_name)
-osx-dmg: osx-dmg-prep
- if [ "`id -u`" != 0 ]; then \
- echo "Root permissions needed to create OSX disk image!"; \
- exit 1; \
- fi
- chown root:wheel $(osx_dmg_name)
.PHONY: test test-markdown
test: $(BINS)