summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-12-19 22:00:41 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-12-19 22:00:41 +0000
commit31a956b65559ea669d5705e005ac3d6641d7518e (patch)
tree2341f56520e94e7b0b46a8b5c96d05a0243fa28d /Makefile
parent206c59a3867ceecce4d1a9374411a889f263911f (diff)
Changes to build process relating to r234.
+ Corrected dependencies in Makefiles to ensure that templates get filled when the relevant files are modified. + Changed template placeholders to @xxx@ instead of <xxx>, for consistency with our practice with the Cabal template. + Changed default font for RTF writer (this had been changed earlier, but in the target rather than the template!) git-svn-id: https://pandoc.googlecode.com/svn/trunk@235 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 369ee5e6f..2f45dce44 100644
--- a/Makefile
+++ b/Makefile
@@ -90,7 +90,6 @@ all: build-program
.PHONY: templates
templates: $(SRCDIR)/templates
-$(SRCDIR)/templates:
$(MAKE) -C $(SRCDIR)/templates
define generate-shell-script
@@ -120,7 +119,7 @@ $(CABAL): cabalize $(CABAL).in $(SRCDIR)/Main.hs
.PHONY: configure
cleanup_files+=$(BUILDDIR) $(BUILDCONF) $(BUILDVARS)
-configure: $(BUILDCONF)
+configure: $(BUILDCONF) templates
$(BUILDCONF): $(CABAL)
$(BUILDCMD) configure --prefix=$(PREFIX)
# Make configuration time settings persistent (definitely a hack).
@@ -128,7 +127,7 @@ $(BUILDCONF): $(CABAL)
@echo "DESTDIR?=$(DESTDIR)" >>$(BUILDVARS)
.PHONY: build
-build: templates configure
+build: configure
$(BUILDCMD) build
.PHONY: build-exec