summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-08-11 07:58:45 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2017-08-11 22:09:15 -0700
commit54cc8e2702b342c09de624240b835efc53666bb7 (patch)
tree7d2ad55bfe77a18ae31cec30b103d443c0c1175e /Makefile
parent83d856ee6c4065bc998832b60ec4347b0f528b6d (diff)
Makefile - disable parallel build on 'make quick'.
Interleaved error messages too confusing.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d73fa6a27..3931dd9d8 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@ RESOLVER=nightly-2017-08-09
GHCOPTS=-fdiagnostics-color=always -Wall -fno-warn-unused-do-bind -Wincomplete-record-updates -Wnoncanonical-monad-instances -Wnoncanonical-monadfail-instances
quick:
- stack install --resolver=$(RESOLVER) --ghc-options='-j4 $(GHCOPTS)' --install-ghc --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4 --hide-successes $(TESTARGS)'
+ stack install --resolver=$(RESOLVER) --ghc-options='$(GHCOPTS)' --install-ghc --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4 --hide-successes $(TESTARGS)'
full:
stack install --resolver=$(RESOLVER) --flag 'pandoc:embed_data_files' --flag 'pandoc:weigh-pandoc' --flag 'pandoc:trypandoc' --bench --no-run-benchmarks --test --test-arguments='-j4 --hide-successes' --ghc-options '-Wall -Werror -fno-warn-unused-do-bind -O0 -j4 $(GHCOPTS)'