summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-08-09 16:51:08 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-08-09 16:51:08 +0000
commit5d3d2d79b3e217e3b420e3d56c5e844e5cae5cf1 (patch)
tree2cb5278f22b77842d177a6c8cd374bd515a7c0a4 /Makefile
parentf1914c21b7dd62cc65e9c4ac20d70986bddd8775 (diff)
Rewrote test suite so it doesn't depend on perl or unix tools.
+ Replaced old runtests.pl with a Haskell script RunTests.hs. + Added Diff.hs module to be used by RunTests.hs instead of unix 'diff'. + Added test hook to Setup.hs, so tests may be run from cabal. + Changed Makefile's 'test' target to run tests via cabal. + Removed old generate.sh. + Since we no longer have 'sed' to filter out raw HTML sections from the docbook writer test, or raw LaTeX sections from the context writer test, we now just include these sections. They can be taken out if it is necessary to process the files. + Updated latex and context writer tests to remove extra spaces after '\\item' + Added a markdown table reader test. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1385 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ba93403cf..5442e3364 100644
--- a/Makefile
+++ b/Makefile
@@ -267,7 +267,7 @@ $(win_pkg_name): $(PKG).exe $(win_docs)
.PHONY: test test-markdown
test: $(MAIN)
- @cd $(TESTDIR) && perl runtests.pl -s $(PWD)/$(MAIN)
+ $(BUILDCMD) test
compat:=$(PWD)/hsmarkdown
markdown_test_dirs:=$(wildcard $(TESTDIR)/MarkdownTest_*)
test-markdown: $(MAIN) $(compat)