summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-03-14 17:05:36 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-03-14 17:07:23 +0100
commit6ecc5b96a9854382682fd1c9231133c08dae7b17 (patch)
tree3703f769c52b951a6233a3b92736b84cc47700ed /Makefile
parent0b4ae3af662587a69e6893b7f6c347d90912c48f (diff)
Use tasty for tests rather than test-framework.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8aa88f2b9..768d62169 100644
--- a/Makefile
+++ b/Makefile
@@ -4,14 +4,14 @@ sourcefiles=$(shell find pandoc.hs src test -name '*.hs')
BRANCH?=master
quick:
- stack install --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4'
+ stack install --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4 --hide-successes'
full:
stack install --flag 'pandoc:embed_data_files' --test --test-arguments='-j4' --pedantic
stack haddock
test:
- stack test --test-arguments='-j4'
+ stack test --flag 'pandoc:embed_data_files' --fast --test-arguments='-j4 --hide-successes'
bench:
stack bench