summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-30 12:10:38 +0000
committerroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-30 12:10:38 +0000
commit93fe9eecc442eb9168f22b4af30c57868717e0e6 (patch)
treed4f645fbb356974bed2ecf403674fd10b876d652 /Makefile
parentbbae8ad31fd4ddafc766636716e61c889030191e (diff)
Modifications to create a nice ChangeLog.
+ Add new file 'gnuify-changelog.pl' grabbed and adapted from subversion distribution. + Add 'ChangeLog' target to create/update ChangeLog. + Update current ChangeLog. git-svn-id: https://pandoc.googlecode.com/svn/trunk@44 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a3b576f9d..3cf5fc882 100644
--- a/Makefile
+++ b/Makefile
@@ -197,6 +197,9 @@ tags: $(src_all)
cd $(SRCDIR) && hasktags -c $(src_all:$(SRCDIR)/%=%); \
LC_ALL=C sort tags >tags.sorted; mv tags.sorted tags
+ChangeLog: ../.svn/entries gnuify-changelog.pl
+ svn log .. | sed 's/(no author)//' | ./gnuify-changelog.pl >$@
+
deb: debian
[ -x /usr/bin/fakeroot ] || { \
echo "*** Please install fakeroot package. ***"; \