summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-02-10 18:59:44 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-02-10 18:59:44 +0000
commit9c9b41e8c6947886551d56b54886a259140856ae (patch)
treea3c77da543366726748945ca01ac6c7ac3a34786 /Makefile
parent0a48cb7de81626bbae577dd59582465401c10bd5 (diff)
Makefile: Add files in templates directory as dependencies for $(BUILDCONF).
git-svn-id: https://pandoc.googlecode.com/svn/trunk@1234 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bd4cecc92..c3f821460 100644
--- a/Makefile
+++ b/Makefile
@@ -126,10 +126,11 @@ ifdef GHC_PKG
else
hc_pkg =
endif
+templates=$(wildcard templates/*.* templates/headers/*.* templates/ui/default/*.*)
configure: $(BUILDCONF)
$(BUILDCMD): Setup.hs
$(GHC) -package Cabal Setup.hs -o $(BUILDCMD)
-$(BUILDCONF): $(CABAL) $(CABAL_BACKUP) $(BUILDCMD)
+$(BUILDCONF): $(CABAL) $(CABAL_BACKUP) $(BUILDCMD) $(templates)
$(BUILDCMD) configure --prefix=$(PREFIX) --with-compiler=$(GHC) $(hc_pkg) $(CABALOPTS)
@# Make configuration time settings persistent (definitely a hack).
@echo "PREFIX?=$(PREFIX)" >$(BUILDVARS)