summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-29 02:03:07 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-29 02:03:07 +0000
commitae5697e3b4b4836023ae868196758e692a9843f8 (patch)
treea1d5f884a311749f74965d3f2336cfc7a828ba31 /Makefile
parentb2fa8c7dd2a4ed11413caa20af66ee9987f84e16 (diff)
Small improvements in Makefile:
+ Added $(BUILDCMD) target, so setup doesn't get compiled every time. + Removed (now circular) dependency of templates on ./templates. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1107 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 6c0d6ee15..99581e610 100644
--- a/Makefile
+++ b/Makefile
@@ -93,7 +93,7 @@ all: build-program
./$(MAIN) -s -S -w man $< >$@ || rm -f $@
.PHONY: templates
-templates: $(SRCDIR)/templates
+templates:
$(MAKE) -C $(SRCDIR)/templates
define generate-shell-script
@@ -128,10 +128,11 @@ $(CABAL_BACKUP):
.PHONY: configure
cleanup_files+=Setup.hi Setup.o $(BUILDCMD) $(BUILDVARS)
configure: $(BUILDCONF) templates
-$(BUILDCONF): $(CABAL) $(CABAL_BACKUP)
+$(BUILDCMD): Setup.hs
$(GHC) -package Cabal Setup.hs -o $(BUILDCMD)
+$(BUILDCONF): $(CABAL) $(CABAL_BACKUP) $(BUILDCMD)
$(BUILDCMD) configure --prefix=$(PREFIX) --with-compiler=$(GHC) --with-hc-pkg=$(GHC_PKG)
- # Make configuration time settings persistent (definitely a hack).
+ @# Make configuration time settings persistent (definitely a hack).
@echo "PREFIX?=$(PREFIX)" >$(BUILDVARS)
@echo "DESTDIR?=$(DESTDIR)" >>$(BUILDVARS)