summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-02-09 03:21:39 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-02-09 03:21:39 +0000
commitc55ac7cd849217bb5260efc24b4b7273c1382b81 (patch)
treed7e7cca4781e8307b53feba3be1041b612982e31 /Makefile
parent04b32451be96cc64e3c8ee37a4b099ffe6236146 (diff)
CABALOPTS may now be specified with 'make'.
For example: CABALOPTS=-fhighlighting make git-svn-id: https://pandoc.googlecode.com/svn/trunk@1222 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6a152b192..bd4cecc92 100644
--- a/Makefile
+++ b/Makefile
@@ -130,7 +130,7 @@ configure: $(BUILDCONF)
$(BUILDCMD): Setup.hs
$(GHC) -package Cabal Setup.hs -o $(BUILDCMD)
$(BUILDCONF): $(CABAL) $(CABAL_BACKUP) $(BUILDCMD)
- $(BUILDCMD) configure --prefix=$(PREFIX) --with-compiler=$(GHC) $(hc_pkg)
+ $(BUILDCMD) configure --prefix=$(PREFIX) --with-compiler=$(GHC) $(hc_pkg) $(CABALOPTS)
@# Make configuration time settings persistent (definitely a hack).
@echo "PREFIX?=$(PREFIX)" >$(BUILDVARS)
@echo "DESTDIR?=$(DESTDIR)" >>$(BUILDVARS)