summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-30 05:40:41 +0000
committerroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-30 05:40:41 +0000
commitfe92360ea2dc3863d3c1bed816037f921706d343 (patch)
treeec840736fc0088428916cb9cef02300c22023d0a /Makefile
parentdb9cebdf9152fe1c3ea1ce324a6b2aceb01807fb (diff)
* cabalize: fix cabal version detection by using a bloody hack.
* Makefile: + Make 'uninstall-all' depends on 'uninstall-exec'. + Make the default target 'all' depends on $(BINS). Now, invoking a plain 'make' builds and creates pandoc in the top directory. git-svn-id: https://pandoc.googlecode.com/svn/trunk@39 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 60afaea8b..b3b68bc45 100644
--- a/Makefile
+++ b/Makefile
@@ -52,7 +52,7 @@ GHC_PKG := ghc-pkg
#-------------------------------------------------------------------------------
.PHONY: all
-all: build
+all: $(BINS)
.PHONY: templates
templates: $(SRCDIR)/templates
@@ -136,7 +136,7 @@ install-all: install-doc install-lib-doc
destdir=$(DESTDIR); destdir=$${destdir:-/}; \
$(BUILDCMD) copy --destdir=$$destdir; \
$(BUILDCMD) register
-uninstall-all: uninstall-doc uninstall-lib-doc
+uninstall-all: uninstall-exec uninstall-doc uninstall-lib-doc
-pkg_id="$(NAME)-$(VERSION)"; \
libdir=$$($(GHC_PKG) field $$pkg_id library-dirs 2>/dev/null | \
sed 's/^library-dirs: *//'); \