summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2017-09-05 14:39:54 +0200
committerJonas Smedegaard <dr@jones.dk>2017-09-05 14:39:54 +0200
commit593baf9d3c53340886d988f2ee0395e1fba62c54 (patch)
treeb7ef48c7ba54e028f79f34b52a1647c2043ec780 /debian/rules
parent0347a8cf2031cf5ef515e817cb575c9ca2725e27 (diff)
Generate and install bash-completion snippet. Build-depend on bash-completion.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 53c2042f6..e45f8f6f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -124,3 +124,12 @@ DEB_SETUP_GHC_CONFIGURE_ARGS += --ghc-options="+RTS -V0 -RTS"
ifneq (,$(filter $(DEB_BUILD_ARCH),mips mipsel))
DEB_SETUP_GHC_CONFIGURE_ARGS += --ghc-options="-optc--param -optcggc-min-expand=10"
endif
+
+CDBS_BUILD_DEPENDS +=, bash-completion
+post-install/$(pkg)::
+ debian/tmp-inst-*/usr/bin/pandoc --bash-completion \
+ > debian/pandoc.bash-completion
+binary-install/$(pkg)::
+ dh_bash-completion
+clean::
+ rm -f debian/pandoc.bash-completion