summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2010-04-21 10:06:23 +0200
committerJonas Smedegaard <dr@jones.dk>2010-04-21 10:10:31 +0200
commitbb9c1380acb2df599ae103a937df3a0ca4ed9556 (patch)
treed5244325acb83c80ae91d086fbe6d88ba01aa3a6 /debian/rules
parent1916dddb8368c08101026563be15b4de305a480a (diff)
Enable threaded RTS only when supported.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 1e6dae2e8..bd637d946 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,9 @@ DEB_INSTALL_MANPAGES_pandoc = man/man1/*.1 debian/hsmarkdown.1
DEB_SETUP_GHC6_CONFIGURE_ARGS = -fhighlighting
+# Use threaded RTS only when supported
+DEB_SETUP_GHC6_CONFIGURE_ARGS += $(if $(wildcard /usr/lib/ghc-$(GHC6_VERSION)/libHSrts_thr.a),--flags=-threaded)
+
# Generate (and cleanup) files containing variables static per build
infiles = $(filter-out debian/control.in, $(wildcard debian/*.in))
outfiles = $(basename $(infiles))