summaryrefslogtreecommitdiff
path: root/linux/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-03-19 16:24:52 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-03-19 16:24:52 +0100
commit74fd00b5f6a776df0fd10d3f4bea58d10ae3a2a3 (patch)
treeb5281ceff47d5e7fe378bbfdb983a456f2fc6c5e /linux/Makefile
parent6756e23f945c7a9c685ac4e8b06eae052f52b574 (diff)
Improved linux tar.gz creation and added Dockerfile to repository.
Diffstat (limited to 'linux/Makefile')
-rw-r--r--linux/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/linux/Makefile b/linux/Makefile
new file mode 100644
index 000000000..798dcba27
--- /dev/null
+++ b/linux/Makefile
@@ -0,0 +1,14 @@
+TREE?=HEAD
+ARTIFACTS=`pwd`/artifacts
+REVISION?=1
+
+build:
+ mkdir -p $(ARTIFACTS)
+ docker build -t alpine-pandoc .
+ docker run --env TREE=$(TREE) --env REVISION=$(REVISION) \
+ -v $(ARTIFACTS):/artifacts alpine-pandoc
+
+setup:
+ docker pull alpine:edge
+
+.PHONY: build setup