summaryrefslogtreecommitdiff
path: root/templates/S5.hs
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-02-09 03:20:42 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-02-09 03:20:42 +0000
commit446a964a190edf094871cd4bb4b045e469446223 (patch)
tree106c01a40bfe59056306e4a0d7fcbd1912f6ce07 /templates/S5.hs
parentc150e84d3c74555d7024c9b0c23a76ef13e73335 (diff)
Incorporated templates phase into Setup.hs and improved templates.
+ Removed templates/Makefile and fillTemplates.pl. + Removed 'templates' Makefile target. + Added postConf hook to Setup.hs that fills the templates. + Use compressed javascripts for S5 and ASCIIMathML templates. + Revised test suite. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1216 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'templates/S5.hs')
-rw-r--r--templates/S5.hs14
1 files changed, 7 insertions, 7 deletions
diff --git a/templates/S5.hs b/templates/S5.hs
index a0b69b132..68787c3db 100644
--- a/templates/S5.hs
+++ b/templates/S5.hs
@@ -48,25 +48,25 @@ s5Meta :: String
s5Meta = "<!-- configuration parameters -->\n<meta name=\"defaultView\" content=\"slideshow\" />\n<meta name=\"controlVis\" content=\"hidden\" />\n"
s5Javascript :: String
-s5Javascript = "<script type=\"text/javascript\">\n@slides.js@</script>\n"
+s5Javascript = "<script type=\"text/javascript\">\n" ++ @slides.js.comment@ ++ @slides.js.packed@ ++ "</script>\n"
s5CoreCSS :: String
-s5CoreCSS = "@s5-core.css@"
+s5CoreCSS = @s5-core.css@
s5FramingCSS :: String
-s5FramingCSS = "@framing.css@"
+s5FramingCSS = @framing.css@
s5PrettyCSS :: String
-s5PrettyCSS = "@pretty.css@"
+s5PrettyCSS = @pretty.css@
s5OperaCSS :: String
-s5OperaCSS = "@opera.css@"
+s5OperaCSS = @opera.css@
s5OutlineCSS :: String
-s5OutlineCSS = "@outline.css@"
+s5OutlineCSS = @outline.css@
s5PrintCSS :: String
-s5PrintCSS = "@print.css@"
+s5PrintCSS = @print.css@
s5CSS :: String
s5CSS = "<style type=\"text/css\" media=\"projection\" id=\"slideProj\">\n" ++ s5CoreCSS ++ "\n" ++ s5FramingCSS ++ "\n" ++ s5PrettyCSS ++ "\n</style>\n<style type=\"text/css\" media=\"projection\" id=\"operaFix\">\n" ++ s5OperaCSS ++ "\n</style>\n<style type=\"text/css\" media=\"screen\" id=\"outlineStyle\">\n" ++ s5OutlineCSS ++ "\n</style>\n<style type=\"text/css\" media=\"print\" id=\"slidePrint\">\n" ++ s5PrintCSS ++ "\n</style>\n"