summaryrefslogtreecommitdiff
path: root/tests/writer.markdown
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-04-10 01:56:50 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-04-10 01:56:50 +0000
commit23df0ed1768c4489d41180e145e98a37fd4ac9fc (patch)
treebb42bf5982f0cdf15d64784897095b2b422a4266 /tests/writer.markdown
parent74e74972260eae3baa69ec254c83c2aaad314e70 (diff)
Extensive changes stemming from a rethinking of the Pandoc data
structure. Key and Note blocks have been removed. Link and image URLs are now stored directly in Link and Image inlines, and note blocks are stored in Note inlines. This requires changes in both parsers and writers. Markdown and RST parsers need to extract data from key and note blocks and insert them into the relevant inline elements. Other parsers can be simplified, since there is no longer any need to construct separate key and note blocks. Markdown, RST, and HTML writers need to construct lists of notes; Markdown and RST writers need to construct lists of link references (when the --reference-links option is specified); and the RST writer needs to construct a list of image substitution references. All writers have been rewritten to use the State monad when state is required. This rewrite yields a small speed boost and considerably cleaner code. * Text/Pandoc/Definition.hs: + blocks: removed Key and Note + inlines: removed NoteRef, added Note + modified Target: there is no longer a 'Ref' target; all targets are explicit URL, title pairs * Text/Pandoc/Shared.hs: + Added 'Reference', 'isNoteBlock', 'isKeyBlock', 'isLineClump', used in some of the readers. + Removed 'generateReference', 'keyTable', 'replaceReferenceLinks', 'replaceRefLinksBlockList', along with some auxiliary functions used only by them. These are no longer needed, since reference links are resolved in the Markdown and RST readers. + Moved 'inTags', 'selfClosingTag', 'inTagsSimple', and 'inTagsIndented' to the Docbook writer, since that is now the only module that uses them. + Changed name of 'escapeSGMLString' to 'escapeStringForXML' + Added KeyTable and NoteTable types + Removed fields from ParserState; 'stateKeyBlocks', 'stateKeysUsed', 'stateNoteBlocks', 'stateNoteIdentifiers', 'stateInlineLinks'. Added 'stateKeys' and 'stateNotes'. + Added clause for Note to 'prettyBlock'. + Added 'writerNotes', 'writerReferenceLinks' fields to WriterOptions. * Text/Pandoc/Entities.hs: Renamed 'escapeSGMLChar' and 'escapeSGMLString' to 'escapeCharForXML' and 'escapeStringForXML' * Text/ParserCombinators/Pandoc.hs: Added lineClump parser: parses a raw line block up to and including following blank lines. * Main.hs: Replaced --inline-links with --reference-links. * README: + Documented --reference-links and removed description of --inline-links. + Added note that footnotes may occur anywhere in the document, but must be at the outer level, not embedded in block elements. * man/man1/pandoc.1, man/man1/html2markdown.1: Removed --inline-links option, added --reference-links option * Markdown and RST readers: + Rewrote to fit new Pandoc definition. Since there are no longer Note or Key blocks, all note and key blocks are parsed on a first pass through the document. Once tables of notes and keys have been constructed, the remaining parts of the document are reassembled and parsed. + Refactored link parsers. * LaTeX and HTML readers: Rewrote to fit new Pandoc definition. Since there are no longer Note or Key blocks, notes and references can be parsed in a single pass through the document. * RST, Markdown, and HTML writers: Rewrote using state monad new Pandoc and definition. State is used to hold lists of references footnotes to and be printed at the end of the document. * RTF and LaTeX writers: Rewrote using new Pandoc definition. (Because of the different treatment of footnotes, the "notes" parameter is no longer needed in the block and inline conversion functions.) * Docbook writer: + Moved the functions 'attributeList', 'inTags', 'selfClosingTag', 'inTagsSimple', 'inTagsIndented' from Text/Pandoc/Shared, since they are now used only by the Docbook writer. + Rewrote using new Pandoc definition. (Because of the different treatment of footnotes, the "notes" parameter is no longer needed in the block and inline conversion functions.) * Updated test suite * Throughout: old haskell98 module names replaced by hierarchical module names, e.g. List by Data.List. * debian/control: Include libghc6-xhtml-dev instead of libghc6-html-dev in "Build-Depends." * cabalize: + Remove haskell98 from BASE_DEPENDS (since now the new hierarchical module names are being used throughout) + Added mtl to BASE_DEPENDS (needed for state monad) + Removed html from GHC66_DEPENDS (not needed since xhtml is now used) git-svn-id: https://pandoc.googlecode.com/svn/trunk@580 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'tests/writer.markdown')
-rw-r--r--tests/writer.markdown67
1 files changed, 26 insertions, 41 deletions
diff --git a/tests/writer.markdown b/tests/writer.markdown
index bae2008dd..a80857cc2 100644
--- a/tests/writer.markdown
+++ b/tests/writer.markdown
@@ -401,7 +401,8 @@ This is code: `>`, `$`, `\`, `\$`, `<html>`.
'He said, "I want to go."' Were you alive in the 70's?
-Here is some quoted '`code`' and a "[quoted link][1]".
+Here is some quoted '`code`' and a
+"[quoted link](http://example.com/?foo=1&bar=2)".
Some dashes: one--two--three--four--five.
@@ -522,57 +523,42 @@ Just a [URL](/url/).
## Reference
-Foo [bar][a].
+Foo [bar](/url/).
-Foo [bar][a].
+Foo [bar](/url/).
-Foo [bar][a].
+Foo [bar](/url/).
+With [embedded [brackets]](/url/).
- [a]: /url/
+[b](/url/) by itself should be a link.
-With [embedded [brackets]][b].
+Indented [once](/url).
-[b][] by itself should be a link.
+Indented [twice](/url).
-Indented [once][].
-
-Indented [twice][].
-
-Indented [thrice][].
+Indented [thrice](/url).
This should [not][] be a link.
-
- [once]: /url
- [twice]: /url
- [thrice]: /url
[not]: /url
-
- [b]: /url/
-
-Foo [bar][].
+Foo [bar](/url/ "Title with "quotes" inside").
Foo [biz](/url/ "Title with "quote" inside").
-
- [bar]: /url/ "Title with "quotes" inside"
-
## With ampersands
-Here's a [link with an ampersand in the URL][1].
+Here's a
+[link with an ampersand in the URL](http://example.com/?foo=1&bar=2).
-Here's a link with an amersand in the link text: [AT&T][2].
+Here's a link with an amersand in the link text:
+[AT&T](http://att.com/ "AT&T").
Here's an [inline link](/script?foo=1&bar=2).
Here's an [inline link in pointy braces](/script?foo=1&bar=2).
-
- [1]: http://example.com/?foo=1&bar=2
- [2]: http://att.com/ "AT&T"
-
## Autolinks
With an ampersand: <http://example.com/?foo=1&bar=2>
@@ -596,10 +582,7 @@ Auto-links should not occur here: `<http://example.com/>`
From "Voyage dans la Lune" by Georges Melies (1902):
-![lalune][]
-
-
- [lalune]: lalune.jpg "Voyage dans la Lune"
+![lalune](lalune.jpg "Voyage dans la Lune")
Here is a movie ![movie](movie.jpg) icon.
@@ -619,25 +602,27 @@ note] Here is an inline note.[^3]
This paragraph should not be part of the note, as it is not
indented.
-[^1]: Here is the footnote. It can go anywhere after the footnote
+
+[^1]:
+ Here is the footnote. It can go anywhere after the footnote
reference. It need not be placed at the end of the document.
-[^2]: Here's the long note. This one contains multiple blocks.
-
+[^2]:
+ Here's the long note. This one contains multiple blocks.
+
Subsequent blocks are indented to show that they belong to the
footnote (as with list items).
-
+
{ <code> }
-
+
If you want, you can indent every line, but you can also be lazy
and just indent the first line of each block.
-[^3]: This is *easier* to type. Inline notes may contain
+[^3]:
+ This is *easier* to type. Inline notes may contain
[links](http://google.com) and `]` verbatim characters.
[^4]: In quote.
-
[^5]: In list.
-