summaryrefslogtreecommitdiff
path: root/web/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-02-19 04:47:12 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-02-19 04:47:12 +0000
commit06ff1feea054f42909776528b73787afaac202f8 (patch)
treebc8a3f10c049af665d9e93241f795708b290c265 /web/Makefile
parent8138fc48aef34ebb8b383d2fc766a617a101bbd3 (diff)
Use 'highlight' to produce syntax-highlighted versions of
xml, html, and tex demo pages (in website /examples/). Add links so that html files can be viewed as web pages (without syntax highlighting). git-svn-id: https://pandoc.googlecode.com/svn/trunk@543 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'web/Makefile')
-rw-r--r--web/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/web/Makefile b/web/Makefile
index b713a05fe..28450c95f 100644
--- a/web/Makefile
+++ b/web/Makefile
@@ -12,6 +12,10 @@ clean:
examples.txt : $(PANDOC_DEPS) mkdemos.pl config.xsl S5DEMO README
PATH=$(PANDOC_PATH):$$PATH ./mkdemos.pl demos $@
+ perl -pi -e 's!(href="(main|(my)?header|footer|example\d+)\.(html|tex|xml|css))"!\1.html"!g' $@
+ for file in $$(ls | egrep '(main|(my)?header|footer|example[0-9]+)\.(html|tex|xml|css)$$'); \
+ do highlight -u utf-8 --style emacs $$file > $$file.html; \
+ done
%.html : %.txt $(PANDOC_DEPS)
$(MAKEPAGE) $< > $@