summaryrefslogtreecommitdiff
path: root/web
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-09-16 16:58:04 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-09-16 16:58:04 +0000
commite00b892bf6959b904cd32927c62c14bb3bac7f6f (patch)
tree890ecf26e2a80ae042e5222dd7aa6db6c3f24870 /web
parent9ed11f4500a04f42d46be8b654f8782d1ef268ec (diff)
Added Google analytics tracking to website.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@1020 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'web')
-rw-r--r--web/Makefile14
-rw-r--r--web/css8
2 files changed, 15 insertions, 7 deletions
diff --git a/web/Makefile b/web/Makefile
index 314573614..e6ecba1d5 100644
--- a/web/Makefile
+++ b/web/Makefile
@@ -1,6 +1,6 @@
ALL := index.html README.html INSTALL.html examples.html pandoc1.html markdown2pdf1.html html2markdown1.html hsmarkdown1.html html2x.html
PANDOC_PATH ?= $(dir $(shell which pandoc))
-MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -c pandoc.css -A footer.html
+MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -H css -A footer.html
all : $(ALL)
.PHONY: clean
@@ -15,22 +15,22 @@ examples.txt : $(PANDOC_DEPS) mkdemos.pl config.xsl S5DEMO README demos
do highlight -k monospace -u utf-8 --style emacs $$file > $$file.html; \
done
-index.html : index.txt
+index.html : index.txt css
$(MAKEPAGE) --toc $< > $@
-README.html : README
+README.html : README css
$(MAKEPAGE) --toc $< > $@
-INSTALL.html : INSTALL
+INSTALL.html : INSTALL css
$(MAKEPAGE) --toc $< > $@
-%.html : %.txt
+%.html : %.txt css
$(MAKEPAGE) $< > $@
-%1.html : %.1
+%1.html : %.1
groff -man -T html $< > $@
-%.html : %
+%.html : % css
$(MAKEPAGE) $< > $@
upload :
diff --git a/web/css b/web/css
new file mode 100644
index 000000000..29f488f2a
--- /dev/null
+++ b/web/css
@@ -0,0 +1,8 @@
+<link rel="stylesheet" type="text/css" href="pandoc.css" media="all" />
+<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
+</script>
+<script type="text/javascript">
+_uacct = "UA-2234613-4";
+urchinTracker();
+</script>
+