summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile1
-rw-r--r--README8
-rw-r--r--web/demos.sh3
-rw-r--r--web/myheader.tex11
4 files changed, 19 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index b0e588696..0985ea38d 100644
--- a/Makefile
+++ b/Makefile
@@ -365,6 +365,7 @@ $(web_dest)/: $(MAIN) html
$(make_page) > $(web_dest)/index.html; \
cp README $(web_dest)/ ; \
./$(MAIN) -s -w latex README > $(web_dest)/README.tex ; \
+ cp $(web_src)/myheader.tex $(web_dest)/ ; \
cp $(web_src)/S5DEMO $(web_dest)/ ; \
cp $(web_src)/header.html $(web_dest)/ ; \
cp $(web_src)/footer.html $(web_dest)/ ; \
diff --git a/README b/README
index 6251cb58d..d3a3e7326 100644
--- a/README
+++ b/README
@@ -57,9 +57,7 @@ The wrapper script `markdown2pdf` requires
- a POSIX-compliant shell
- `pdflatex`, which should be part of any [LaTeX] distribution
- the [unicode] and [fancyvrb] LaTeX packages, which are included
- in many LaTeX distributions. The [unicode] package allows LaTeX to
- process UTF-8 characters. [fancyvrb] allows code blocks and verbatim
- text to be used within footnotes. If your installation of LaTeX
+ in many LaTeX distributions.[^1] If your installation of LaTeX
does not include these packages, you will get an error (complaining
about missing `ucs.sty` or `fancyvrb.sty`) when you try to compile
a LaTeX file produced by Pandoc, or when you use the `markdown2pdf`
@@ -72,6 +70,10 @@ The wrapper script `markdown2pdf` requires
[unicode]: http://www.ctan.org/tex-archive/macros/latex/contrib/unicode/
[fancyvrb]: http://www.ctan.org/tex-archive/macros/latex/contrib/fancyvrb/
+[^1]: The [unicode] package allows LaTeX to process UTF-8 characters.
+[fancyvrb] allows code blocks and verbatim text to be used within
+footnotes.
+
Using Pandoc
============
diff --git a/web/demos.sh b/web/demos.sh
index 7dbada910..6c6a2a698 100644
--- a/web/demos.sh
+++ b/web/demos.sh
@@ -15,7 +15,8 @@ pandoc -s -w rst README -o demo0.txt
pandoc -s README -o demo0.rtf
pandoc -s -m -i -w s5 S5DEMO -o demo0.html
web2markdown http://www.gnu.org/software/make/ -o demo0.txt
-markdown2pdf README -o demo0.pdf'
+markdown2pdf README -o demo0.pdf
+markdown2pdf -C myheader.tex README -o demo0.pdf'
oldifs=$IFS
IFS=$NEWLINE
diff --git a/web/myheader.tex b/web/myheader.tex
new file mode 100644
index 000000000..a3de3622f
--- /dev/null
+++ b/web/myheader.tex
@@ -0,0 +1,11 @@
+\documentclass[12pt]{article}
+\usepackage{txfonts}
+\usepackage{hyperref}
+\usepackage{ucs}
+\usepackage[utf8x]{inputenc}
+\usepackage{graphicx}
+\setlength{\parindent}{0pt}
+\setlength{\parskip}{6pt plus 2pt minus 1pt}
+% This is needed for code blocks in footnotes:
+\usepackage{fancyvrb}
+\VerbatimFootnotes