summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile1
-rw-r--r--src/templates/Makefile4
2 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2f45dce44..31bec5a15 100644
--- a/Makefile
+++ b/Makefile
@@ -380,5 +380,6 @@ distclean: clean
fi
clean:
+ make -C $(SRCDIR)/templates clean
-if [ -f $(BUILDCONF) ]; then $(BUILDCMD) clean; fi
-rm -rf $(cleanup_files)
diff --git a/src/templates/Makefile b/src/templates/Makefile
index c3256b87e..9522666c5 100644
--- a/src/templates/Makefile
+++ b/src/templates/Makefile
@@ -14,3 +14,7 @@ Text/Pandoc/Writers/S5.hs: S5.hs $(PROCESSOR) $(VPATH)/ui/default/*
Text/Pandoc/Writers/DefaultHeaders.hs: DefaultHeaders.hs $(PROCESSOR) $(VPATH)/headers/*
perl $(PROCESSOR) $@ $(VPATH)
+
+.PHONY: clean
+clean:
+ cd $(VPATH); rm -f $(TARGETS)