summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore4
-rw-r--r--CONTRIBUTING.md8
-rw-r--r--INSTALL2
-rw-r--r--MANUAL.txt (renamed from README)0
-rw-r--r--Makefile2
-rw-r--r--appveyor.yml2
-rw-r--r--pandoc.cabal4
-rw-r--r--src/Text/Pandoc/Data.hsb2
-rw-r--r--src/Text/Pandoc/Shared.hs4
-rw-r--r--windows/make-windows-installer.bat4
-rw-r--r--windows/pandoc.wxs20
11 files changed, 26 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
index 9b7630a4c..0e2686c83 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
*~
dist/*
-README.*
-!README.Debian
+MANUAL.*
+!MANUAL.txt
INSTALL.*
.configure-stamp
.cabal-sandbox
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index f39acab10..31d786214 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -29,7 +29,7 @@ Out of scope?
-------------
A less than perfect conversion does not necessarily mean there's
-a bug in pandoc. Quoting from the README:
+a bug in pandoc. Quoting from the MANUAL:
> Because Pandoc's intermediate representation of a document is less
> expressive than many of the formats it converts between, one should
@@ -124,7 +124,7 @@ Please follow these guidelines:
below under [Tests](#tests).) If you are adding a new writer or reader,
you must include tests.
-7. If you are adding a new feature, include updates to the README.
+7. If you are adding a new feature, include updates to the README and MANUAL.
8. All code must be released under the general license governing pandoc
(GPL v2).
@@ -259,7 +259,7 @@ The library is structured as follows:
- `Text.Pandoc.Shared` is a grab-bag of shared utility functions.
- `Text.Pandoc.Writers.Shared` contains utilities used in writers only.
- `Text.Pandoc.Slides` contains functions for splitting a markdown document
- into slides, using the conventions described in the README.
+ into slides, using the conventions described in the MANUAL.
- `Text.Pandoc.Templates` defines pandoc's templating system.
- `Text.Pandoc.UTF8` contains functions for converting text to and from
UTF8 bytestrings (strict and lazy).
@@ -270,7 +270,7 @@ The library is structured as follows:
[pandoc-discuss]: http://groups.google.com/group/pandoc-discuss
[issue tracker]: https://github.com/jgm/pandoc/issues
-[User's Guide]: http://pandoc.org/README.html
+[User's Guide]: http://pandoc.org/MANUAL.html
[FAQs]: http://pandoc.org/faqs.html
[EditorConfig]: http://editorconfig.org/
[Haskell platform]: http://www.haskell.org/platform/
diff --git a/INSTALL b/INSTALL
index bfb548913..87be44eca 100644
--- a/INSTALL
+++ b/INSTALL
@@ -95,7 +95,7 @@ Quick install with cabal
The `pandoc.1` man page will be installed automatically. cabal shows
you where it is installed: you may need to set your `MANPATH`
-accordingly. If `README` has been modified, the man page can be
+accordingly. If `MANUAL.txt` has been modified, the man page can be
rebuilt: `make man/pandoc.1`.
The `pandoc-citeproc.1` man page will also be installed automatically.
diff --git a/README b/MANUAL.txt
index 8d5be98f8..8d5be98f8 100644
--- a/README
+++ b/MANUAL.txt
diff --git a/Makefile b/Makefile
index 00eb51321..19d0a50af 100644
--- a/Makefile
+++ b/Makefile
@@ -56,7 +56,7 @@ pandoc-$(version)-windows.msi:
osslsigncode sign -pkcs12 ~/Private/ComodoCodeSigning.exp2017.p12 -in pandoc.msi -i http://johnmacfarlane.net/ -t http://timestamp.comodoca.com/ -out $@ -askpass
rm pandoc.msi
-man/pandoc.1: README man/pandoc.1.template
+man/pandoc.1: MANUAL.txt man/pandoc.1.template
pandoc $< -t man -s --template man/pandoc.1.template \
--filter man/capitalizeHeaders.hs \
--filter man/removeNotes.hs \
diff --git a/appveyor.yml b/appveyor.yml
index 7ce7dc171..e7728dba5 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -37,7 +37,7 @@ after_test:
# .\ in the stack commandline seems to be .\windows\ (where the stack-appveyor.yaml is)
- cd windows
- 7z a "pandoc.zip" pandoc.exe
- - .\pandoc.exe -s -S --toc ..\README -o README.html
+ - .\pandoc.exe -s -S --toc ..\MANUAL.txt -o MANUAL.html
- .\pandoc.exe -s -S ..\COPYING -o COPYING.rtf
- copy ..\COPYRIGHT COPYRIGHT.txt
- |
diff --git a/pandoc.cabal b/pandoc.cabal
index 140390c98..9599f4f80 100644
--- a/pandoc.cabal
+++ b/pandoc.cabal
@@ -105,10 +105,10 @@ Data-Files:
-- bash completion template
data/bash_completion.tpl
-- documentation
- README, COPYRIGHT
+ MANUAL.txt, COPYRIGHT
Extra-Source-Files:
-- documentation
- INSTALL, BUGS, CONTRIBUTING.md, changelog
+ INSTALL, BUGS, README.md, CONTRIBUTING.md, changelog
man/pandoc.1
-- stack build plan
stack.yaml
diff --git a/src/Text/Pandoc/Data.hsb b/src/Text/Pandoc/Data.hsb
index d408bf510..8786647c5 100644
--- a/src/Text/Pandoc/Data.hsb
+++ b/src/Text/Pandoc/Data.hsb
@@ -12,4 +12,4 @@ dataFiles = map (\(fp, contents) ->
(Posix.joinPath (splitDirectories fp), contents)) dataFiles'
dataFiles' :: [(FilePath, B.ByteString)]
-dataFiles' = ("README", %blob "README") : %blobs "data"
+dataFiles' = ("MANUAL.txt", %blob "MANUAL.txt") : %blobs "data"
diff --git a/src/Text/Pandoc/Shared.hs b/src/Text/Pandoc/Shared.hs
index cc834a69a..bd299a802 100644
--- a/src/Text/Pandoc/Shared.hs
+++ b/src/Text/Pandoc/Shared.hs
@@ -873,7 +873,7 @@ readDefaultDataFile fname =
go as x = x : as
#else
getDataFileName fname' >>= checkExistence >>= BS.readFile
- where fname' = if fname == "README" then fname else "data" </> fname
+ where fname' = if fname == "MANUAL.txt" then fname else "data" </> fname
checkExistence :: FilePath -> IO FilePath
checkExistence fn = do
@@ -1071,7 +1071,7 @@ blocksToInlinesWithSep sep blks = intercalate sep $ map blockToInlines blks
blocksToInlines :: [Block] -> [Inline]
blocksToInlines = blocksToInlinesWithSep [Space, Str "¶", Space]
-
+
--
-- Safe read
diff --git a/windows/make-windows-installer.bat b/windows/make-windows-installer.bat
index 892a61cdc..75fd01b4f 100644
--- a/windows/make-windows-installer.bat
+++ b/windows/make-windows-installer.bat
@@ -2,7 +2,7 @@
stack install --test
if %errorlevel% neq 0 exit /b %errorlevel%
for /f "delims=" %%a in ('stack path --local-bin-path') do @set BINPATH=%%a
-%BINPATH%\pandoc.exe -s -S --toc ..\README -o README.html
+%BINPATH%\pandoc.exe -s -S --toc ..\MANUAL -o MANUAL.html
if %errorlevel% neq 0 exit /b %errorlevel%
%BINPATH%\pandoc.exe -s ..\COPYING -t rtf -S -o COPYING.rtf
if %errorlevel% neq 0 exit /b %errorlevel%
@@ -14,7 +14,7 @@ for /f "tokens=1-2 delims= " %%a in ('%BINPATH%\pandoc.exe --version') do (
:next
if "%VERSION%" == "" (
echo Error: could not determine version number.
- exit /b 1
+ exit /b 1
)
echo Detected version %VERSION%
echo Creating msi...
diff --git a/windows/pandoc.wxs b/windows/pandoc.wxs
index 50a686e55..dcdd3f582 100644
--- a/windows/pandoc.wxs
+++ b/windows/pandoc.wxs
@@ -57,8 +57,8 @@
<Component Id="Documentation"
Guid="A8D54A76-1A3D-4647-8327-81B69D39D8A3">
- <File Id="pandocREADME" Name="Pandoc User's Guide.html"
- Source="README.html" KeyPath="yes">
+ <File Id="pandocMANUAL" Name="Pandoc User's Guide.html"
+ Source="MANUAL.html" KeyPath="yes">
<Shortcut Id="ApplicationStartMenuShortcut"
Directory="ApplicationProgramsFolder"
Name="Pandoc User’s Guide" Advertise="yes" />
@@ -123,18 +123,18 @@
</Feature>
</Feature>
-
+
<!-- Set properties for add/remove programs -->
<Property Id="ARPURLINFOABOUT" Value="http://pandoc.org" />
<Property Id="ARPHELPLINK" Value="http://pandoc.org" />
<Property Id="ARPNOREPAIR" Value="yes" Secure="yes" /> <!-- Remove repair -->
<Property Id="ARPNOMODIFY" Value="yes" Secure="yes" /> <!-- Remove modify -->
-
+
<!--Needed for WixUI_Advanced-->
<Property Id="ApplicationFolderName" Value="Pandoc" />
<Property Id="WixAppFolder" Value="WixPerUserFolder" />
-
+
<!--For Single Package for dual purpose i.e. per User/Machine-->
<!--<Property Id="ALLUSERS" Value="2" Secure="yes" />-->
<Property Id="MSIINSTALLPERUSER" Value="1" />
@@ -145,7 +145,7 @@
<CustomAction Id="SetExitDialogOptText"
Property="WIXUI_EXITDIALOGOPTIONALTEXT"
Value="!(loc.ExitDialogText)" />
-
+
<!--Offer Per User installs only on workstations (block on servers)-->
<!--Unless ALLUSERS=1 is specified on command line-->
<SetProperty Id="WixUISupportPerUser" Value="0" Before="FindRelatedProducts">
@@ -177,12 +177,12 @@
NOT Installed
</Custom>
</InstallUISequence>
-
+
<UIRef Id="WixUI_Advanced_Custom"/>
<!--Enable better description when debug logging-->
<UIRef Id="WixUI_ErrorProgressText" />
-
+
</Product>
-
-
+
+
</Wix>