summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2022-08-12 15:48:24 +0100
committerJeremy Bicha <jbicha@ubuntu.com>2022-12-15 14:20:25 +0000
commit041c03b5d6345b8a187edd1b7770255c43f6a8f1 (patch)
tree418b13111b5a9cbeee6398c44ee1790983d27dc3
parent62f175cb2da01f3f24c1084829dc22061b6f939e (diff)
Work around #1014417 in Meson
Forwarded: not-needed, Meson should be fixed instead Gbp-Pq: Topic debian Gbp-Pq: Name Work-around-1014417-in-Meson.patch
-rw-r--r--tests/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6c1c461b..09b7c8ac 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -2,6 +2,13 @@ test_cflags = [
'-DSRCDIR=@0@'.format(meson.current_source_dir()),
]
+if meson.version() == '0.63.0'
+ # Work around https://github.com/mesonbuild/meson/issues/10577
+ tap_test_protocol = 'exitcode'
+else
+ tap_test_protocol = 'tap'
+endif
+
if xft_dep.found()
test_cflags += [ '-DHAVE_X', '-DHAVE_XFT' ]
endif
@@ -307,6 +314,6 @@ foreach t: tests
args: ['-k', '--tap'],
env: test_env,
suite: 'pango',
- protocol: 'tap',
+ protocol: tap_test_protocol,
)
endforeach