summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2022-03-14 00:09:19 -0400
committerMatthias Clasen <mclasen@redhat.com>2022-03-14 00:12:28 -0400
commit2d0287de702cba1ae624fb88fd87036840e7081f (patch)
treec143b87c67c86e1a4ec7e23f4f7f84a1c9145b4a /tests/meson.build
parent5243a5565fdf17460ae4e53bbbadb78cb07e8e26 (diff)
Add a fontset test
This tests that our test font configuration produces the expected font enumerations.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 84fe3370..955dbc99 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -62,6 +62,7 @@ if cairo_dep.found()
if host_system != 'darwin'
tests += [
[ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep, libpangoft2_dep ] ],
+ [ 'test-fonts', [ 'test-fonts.c', 'test-common.c' ], [ libpangocairo_dep, libpangoft2_dep ] ],
]
endif
endif
@@ -127,6 +128,13 @@ installed_test_layouts_data = [
'layouts/letterspacing.layout',
]
+installed_test_fontsets_data = [
+ 'fontsets/cantarell',
+ 'fontsets/cantarell2',
+ 'fontsets/mono',
+ 'fontsets/mono2',
+]
+
installed_test_fonts_data = [
'fonts/amiri-06dd.ttf',
'fonts/Cantarell-VF.otf',
@@ -251,6 +259,7 @@ if get_option('install-tests')
install_data(installed_test_markups_data, install_dir: join_paths(installed_test_bindir, 'markups'))
install_data(installed_test_breaks_data, install_dir: join_paths(installed_test_bindir, 'breaks'))
install_data(installed_test_items_data, install_dir: join_paths(installed_test_bindir, 'itemize'))
+ install_data(installed_test_fontsets_data, install_dir: join_paths(installed_test_bindir, 'fontsets'))
endif
gen_installed_test = files([ 'gen-installed-test.py' ])