summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6c1c461b..09b7c8ac 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -2,6 +2,13 @@ test_cflags = [
'-DSRCDIR=@0@'.format(meson.current_source_dir()),
]
+if meson.version() == '0.63.0'
+ # Work around https://github.com/mesonbuild/meson/issues/10577
+ tap_test_protocol = 'exitcode'
+else
+ tap_test_protocol = 'tap'
+endif
+
if xft_dep.found()
test_cflags += [ '-DHAVE_X', '-DHAVE_XFT' ]
endif
@@ -307,6 +314,6 @@ foreach t: tests
args: ['-k', '--tap'],
env: test_env,
suite: 'pango',
- protocol: 'tap',
+ protocol: tap_test_protocol,
)
endforeach