summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2020-08-29 12:03:40 -0400
committerFelipe Sateler <fsateler@debian.org>2020-08-29 12:03:40 -0400
commit77491da34a860663eb38626910aa8913aa9d3c9c (patch)
tree14a0243a4845e0305bab8e40480787043ecdde94 /src/Makefile.am
Import patchelf_0.12.orig.tar.gz
[dgit import orig patchelf_0.12.orig.tar.gz]
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b9aee08
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,9 @@
+AM_CXXFLAGS = -Wall -std=c++11 -D_FILE_OFFSET_BITS=64
+
+if WITH_ASAN
+AM_CXXFLAGS += -fsanitize=address -fno-optimize-sibling-calls -fsanitize-address-use-after-scope -fno-omit-frame-pointer -g -O1
+endif
+
+bin_PROGRAMS = patchelf
+
+patchelf_SOURCES = patchelf.cc elf.h