summaryrefslogtreecommitdiff
path: root/debian/patches/drop-optimization-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/drop-optimization-flags.patch')
-rw-r--r--debian/patches/drop-optimization-flags.patch16
1 files changed, 9 insertions, 7 deletions
diff --git a/debian/patches/drop-optimization-flags.patch b/debian/patches/drop-optimization-flags.patch
index 7e5be33..f500f5d 100644
--- a/debian/patches/drop-optimization-flags.patch
+++ b/debian/patches/drop-optimization-flags.patch
@@ -13,9 +13,11 @@ Last-Update: 2022-09-04
Makefile.pdlibbuilder | 7 +++++++
1 file changed, 7 insertions(+)
---- pd-lib-builder.orig/Makefile.pdlibbuilder
-+++ pd-lib-builder/Makefile.pdlibbuilder
-@@ -473,6 +473,9 @@
+diff --git a/Makefile.pdlibbuilder b/Makefile.pdlibbuilder
+index 38a1220..6ad2706 100644
+--- a/Makefile.pdlibbuilder
++++ b/Makefile.pdlibbuilder
+@@ -473,6 +473,9 @@ endif
# arch.c.flags are overriden below. To see gcc's default architecture flags:
# $ gcc -Q --help=target
@@ -25,14 +27,14 @@ Last-Update: 2022-09-04
# ARMv6: Raspberry Pi 1st gen, not detectable from target.arch
ifeq ($(shell uname -m), armv6l)
arch.c.flags = -march=armv6 -mfpu=vfp -mfloat-abi=hard
-@@ -497,6 +500,10 @@
- else
+@@ -498,6 +501,10 @@ else
arch.c.flags =
endif
-+
+
+else
+ arch.c.flags =
+endif
-
++
#=== flags and paths for Linux =================================================
+