summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2018-01-30 20:33:39 +0100
committerIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2018-01-30 20:33:39 +0100
commit4b6ae99bb7a0c01fe6c83b908157a1092a6aa1bb (patch)
tree45c00b57a4fe92a74b01859f65b9a34dfb10d731 /debian
parent8bf114e4e785f24b778298e8e2cf08e96cb581b3 (diff)
Simplified & unified d/rules
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules29
1 files changed, 21 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index ab7d28f..cac2654 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,30 @@
#!/usr/bin/make -f
+# Copyright © 2010 Hans-Christoph Steiner <hans@eds.org>
+# Copyright © 2018 IOhannes m zmölnig <umlaeute@debian.org>
-LIBRARY_NAME = maxlib
-PACKAGE = pd-$(LIBRARY_NAME)
pkglibdir = /usr/lib/pd/extra
%:
- dh $@ --buildsystem=makefile
+ dh $@
+
+override_dh_auto_build:
+ dh_auto_build -- \
+ arch.flags="" \
+ CPPFLAGS="$(CPPFLAGS)" \
+ CFLAGS="$(CFLAGS)" \
+ LDFLAGS="$(LDFLAGS) -Wl,-as-needed" \
+ $(empty)
override_dh_auto_install:
dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
-# replace license file with link to the Debian license file
- rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+# fix permissions
+ find $(CURDIR)/debian/*/$(pkglibdir) -name "*.pd_linux" -exec \
+ chmod 0664 {} +
+# remove license file so we can replace it with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/*/$(pkglibdir)/*/LICENSE.txt
-override_dh_shlibdeps:
- dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
- -T$(CURDIR)/debian/$(PACKAGE).substvars
+licensecheck:
+ licensecheck --deb-machine -r * \
+ > debian/copyright_newhints
+ cmp debian/copyright_hints debian/copyright_newhints \
+ && rm debian/copyright_newhints