summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorChristoph Egger <christoph@christoph-egger.org>2017-01-25 10:51:28 +0100
committerChristoph Egger <christoph@christoph-egger.org>2017-01-25 10:51:28 +0100
commit6e289327635da561225e54b4e6b5f9baa01042e7 (patch)
tree54364a76d30ed01c3e7a2f0738a5f675c4485daa /Makefile.in
parent5470c465b2c8ce6a361c875b095a45469056628a (diff)
Imported Upstream version 2.0
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in34
1 files changed, 25 insertions, 9 deletions
diff --git a/Makefile.in b/Makefile.in
index 728766d..f534a4e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -85,6 +85,8 @@ POST_INSTALL = :
NORMAL_UNINSTALL = :
PRE_UNINSTALL = :
POST_UNINSTALL = :
+build_triplet = @build@
+host_triplet = @host@
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/ax_cxx_compile_stdcxx_11.m4 \
@@ -157,7 +159,8 @@ CTAGS = ctags
CSCOPE = cscope
DIST_SUBDIRS = $(SUBDIRS)
am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in AUTHORS \
- COPYING INSTALL NEWS TODO compile depcomp install-sh missing
+ COPYING INSTALL compile config.guess config.sub depcomp \
+ install-sh missing
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -218,7 +221,6 @@ CXXDEPMODE = @CXXDEPMODE@
CXXFLAGS = @CXXFLAGS@
CYGPATH_W = @CYGPATH_W@
DEFS = @DEFS@
-DEJAGNU = @DEJAGNU@
DEPDIR = @DEPDIR@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
@@ -229,14 +231,16 @@ GREP = @GREP@
HAVE_A2X = @HAVE_A2X@
HAVE_CXX11 = @HAVE_CXX11@
HAVE_GCOV = @HAVE_GCOV@
-HAVE_GENHTML = @HAVE_GENHTML@
-HAVE_LCOV = @HAVE_LCOV@
+HAVE_GCOVR = @HAVE_GCOVR@
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
+LIBGCRYPT_CFLAGS = @LIBGCRYPT_CFLAGS@
+LIBGCRYPT_CONFIG = @LIBGCRYPT_CONFIG@
+LIBGCRYPT_LIBS = @LIBGCRYPT_LIBS@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LTLIBOBJS = @LTLIBOBJS@
@@ -271,7 +275,11 @@ am__quote = @am__quote@
am__tar = @am__tar@
am__untar = @am__untar@
bindir = @bindir@
+build = @build@
build_alias = @build_alias@
+build_cpu = @build_cpu@
+build_os = @build_os@
+build_vendor = @build_vendor@
builddir = @builddir@
cov_CFLAGS = @cov_CFLAGS@
cov_LDFLAGS = @cov_LDFLAGS@
@@ -280,7 +288,11 @@ datarootdir = @datarootdir@
docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
+host = @host@
host_alias = @host_alias@
+host_cpu = @host_cpu@
+host_os = @host_os@
+host_vendor = @host_vendor@
htmldir = @htmldir@
includedir = @includedir@
infodir = @infodir@
@@ -311,7 +323,7 @@ top_srcdir = @top_srcdir@
unac_CFLAGS = @unac_CFLAGS@
unac_LIBS = @unac_LIBS@
ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = autogen.sh README.asciidoc HACKING
+EXTRA_DIST = autogen.sh README.md CONTRIBUTING.md NEWS.md
SUBDIRS = src completion doc testsuite
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
@@ -537,7 +549,7 @@ distdir: $(DISTFILES)
! -type d ! -perm -444 -exec $(install_sh) -c -m a+r {} {} \; \
|| chmod -R a+r "$(distdir)"
dist-gzip: distdir
- tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
+ tardir=$(distdir) && $(am__tar) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).tar.gz
$(am__post_remove_distdir)
dist-bzip2: distdir
@@ -563,7 +575,7 @@ dist-shar: distdir
@echo WARNING: "Support for shar distribution archives is" \
"deprecated." >&2
@echo WARNING: "It will be removed altogether in Automake 2.0" >&2
- shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
+ shar $(distdir) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).shar.gz
$(am__post_remove_distdir)
dist-zip: distdir
@@ -581,7 +593,7 @@ dist dist-all:
distcheck: dist
case '$(DIST_ARCHIVES)' in \
*.tar.gz*) \
- GZIP=$(GZIP_ENV) gzip -dc $(distdir).tar.gz | $(am__untar) ;;\
+ eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).tar.gz | $(am__untar) ;;\
*.tar.bz2*) \
bzip2 -dc $(distdir).tar.bz2 | $(am__untar) ;;\
*.tar.lz*) \
@@ -591,7 +603,7 @@ distcheck: dist
*.tar.Z*) \
uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
*.shar.gz*) \
- GZIP=$(GZIP_ENV) gzip -dc $(distdir).shar.gz | unshar ;;\
+ eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).shar.gz | unshar ;;\
*.zip*) \
unzip $(distdir).zip ;;\
esac
@@ -797,6 +809,10 @@ uninstall-am:
@ENABLE_COV_TRUE@.PHONY: cov-report
@ENABLE_COV_TRUE@cov-report:
+@ENABLE_COV_TRUE@ @gcovr -r src/
+
+@ENABLE_COV_TRUE@.PHONY: cov-report-html
+@ENABLE_COV_TRUE@cov-report-html: coverage
@ENABLE_COV_TRUE@ @mkdir -p coverage_report
@ENABLE_COV_TRUE@ @lcov --directory src/ --capture --no-external --output-file coverage_report/pdfgrep.info
@ENABLE_COV_TRUE@ @genhtml -o coverage_report/ coverage_report/pdfgrep.info