summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthias Klose <doko@debian.org>2014-07-13 17:50:59 +0200
committerMatthias Klose <doko@debian.org>2014-07-13 17:50:59 +0200
commita1959ba9c0c9f3881c3e593e5aef1046750880f2 (patch)
treee4fc630e9e26b227d9a7e41db65d80f6158e8ae9 /setup.py
pdfrw (0.1-3) unstable; urgency=medium
* QA upload. * Build using dh_python2 # imported from the archive
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..84fc9cf
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,38 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(
+ name='pdfrw',
+ version='0.1',
+ description='PDF file reader/writer library',
+ long_description='''
+pdfrw lets you read and write PDF files, including
+compositing multiple pages together (e.g. to do watermarking,
+or to copy an image or diagram from one PDF to another),
+and can output by itself, or in conjunction with reportlab.
+
+pdfrw will faithfully reproduce vector formats without
+rasterization, so the rst2pdf package has used pdfrw
+by default for PDF and SVG images by default since
+March 2010. Several small examples are provided.
+''',
+ author='Patrick Maupin',
+ author_email='pmaupin@gmail.com',
+ platforms="Independent",
+ url='http://code.google.com/p/pdfrw/',
+ packages=['pdfrw', 'pdfrw.objects'],
+ license="MIT",
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Multimedia :: Graphics :: Graphics Conversion',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Utilities'
+ ],
+ keywords='pdf vector graphics',
+)